summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-09 19:40:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-09 19:40:01 +0000
commit41295e04d4c55c8db1cef6327f96ce34d53f8f7e (patch)
tree5d65d819a392c4e217aa50536b3aa8c63a14d81c /dev-ruby/childlabor
parentVersion bump. (diff)
downloadgentoo-2-41295e04d4c55c8db1cef6327f96ce34d53f8f7e.tar.gz
gentoo-2-41295e04d4c55c8db1cef6327f96ce34d53f8f7e.tar.bz2
gentoo-2-41295e04d4c55c8db1cef6327f96ce34d53f8f7e.zip
Add ruby20 target. Add snapshot from github to provide tests.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/childlabor')
-rw-r--r--dev-ruby/childlabor/ChangeLog7
-rw-r--r--dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/childlabor/ChangeLog b/dev-ruby/childlabor/ChangeLog
index c50d134153c5..d3e8bfdf59e0 100644
--- a/dev-ruby/childlabor/ChangeLog
+++ b/dev-ruby/childlabor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/childlabor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childlabor/ChangeLog,v 1.4 2013/01/15 06:59:20 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childlabor/ChangeLog,v 1.5 2013/11/09 19:40:01 mrueg Exp $
+
+*childlabor-0.0.3-r1 (09 Nov 2013)
+
+ 09 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +childlabor-0.0.3-r1.ebuild:
+ Add ruby20 target. Add snapshot from github to provide tests.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> childlabor-0.0.3.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild b/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..6f098903181b
--- /dev/null
+++ b/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild,v 1.1 2013/11/09 19:40:01 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="https://github.com/carllerche/childlabor"
+COMMIT_ID="6518b939dddbad20c7f05aa075d76e3ca6e70447"
+SRC_URI="https://github.com/carllerche/childlabor/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="test"
+
+RUBY_S="${PN}-${COMMIT_ID}"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+each_ruby_test() {
+ ${RUBY} -I. -Ilib -S rspec spec/task_spec.rb || die
+}