summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Wilmott <p8952@gentoo.org>2014-05-09 20:45:27 +0000
committerPeter Wilmott <p8952@gentoo.org>2014-05-09 20:45:27 +0000
commit6da55b1df1aaca4031cc37837c13571645e9e038 (patch)
tree683b9b0d7905c14760d10e1ebcb9512e8d5ea114 /dev-ruby/bcat/bcat-0.6.2-r2.ebuild
parentVersion bump (diff)
downloadgentoo-2-6da55b1df1aaca4031cc37837c13571645e9e038.tar.gz
gentoo-2-6da55b1df1aaca4031cc37837c13571645e9e038.tar.bz2
gentoo-2-6da55b1df1aaca4031cc37837c13571645e9e038.zip
Add ruby21 target.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-ruby/bcat/bcat-0.6.2-r2.ebuild')
-rw-r--r--dev-ruby/bcat/bcat-0.6.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/bcat/bcat-0.6.2-r2.ebuild b/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
new file mode 100644
index 000000000000..7a3bb85e12ee
--- /dev/null
+++ b/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/bcat-0.6.2-r2.ebuild,v 1.1 2014/05/09 20:45:27 p8952 Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="man"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pipe to browser utility for use at the shell and within editors like Vim or Emacs."
+HOMEPAGE="http://github.com/rtomayko/bcat"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Collides on /usr/bin/bcat, bug 418301
+RDEPEND="${RDEPEND} !!app-accessibility/speech-tools"
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+ruby_add_rdepend "dev-ruby/rack"
+
+each_ruby_prepare() {
+ sed -i -e "s/a2h/#{ENV['RUBY']} -S a2h/" test/test_bcat_a2h.rb || die
+}
+
+each_ruby_test() {
+ # The Rakefile uses weird trickery with load path that causes gems
+ # not to be found. Run tests directly instead and do the trickery
+ # here to support popen calls for the bins in this package.
+ RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/*.1
+}