summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-27 06:15:11 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-27 06:15:11 +0000
commitbca667847cc1ada08f6ee3a530d7c2e111ea2880 (patch)
treebcaf00fae5457783d4d73833599c3210874c6db8 /dev-ruby/addressable
parentCleanup. (diff)
downloadgentoo-2-bca667847cc1ada08f6ee3a530d7c2e111ea2880.tar.gz
gentoo-2-bca667847cc1ada08f6ee3a530d7c2e111ea2880.tar.bz2
gentoo-2-bca667847cc1ada08f6ee3a530d7c2e111ea2880.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/ChangeLog7
-rw-r--r--dev-ruby/addressable/addressable-2.3.4.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index a4269e89b17e..ee30acedff08 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/addressable
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.31 2013/04/27 06:10:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.32 2013/04/27 06:15:11 graaff Exp $
+
+*addressable-2.3.4 (27 Apr 2013)
+
+ 27 Apr 2013; Hans de Graaff <graaff@gentoo.org> +addressable-2.3.4.ebuild:
+ Version bump.
27 Apr 2013; Hans de Graaff <graaff@gentoo.org> -addressable-2.3.2.ebuild:
Cleanup.
diff --git a/dev-ruby/addressable/addressable-2.3.4.ebuild b/dev-ruby/addressable/addressable-2.3.4.ebuild
new file mode 100644
index 000000000000..3d4302e38757
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.3.4.ebuild,v 1.1 2013/04/27 06:15:10 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library."
+HOMEPAGE="http://addressable.rubyforge.org/"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+}