summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-19 11:00:59 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-19 11:00:59 +0000
commitecf86e5aae2f2a37f0f5ad5430f742ad12447eea (patch)
tree7c5cc87c51094e0597e1f14bcf6eaf7ce65b63e0 /dev-ruby/activeresource
parentMove sed from src_unpack to src_prepare to avoid EAPI=4 repoman warnings. (diff)
downloadgentoo-2-ecf86e5aae2f2a37f0f5ad5430f742ad12447eea.tar.gz
gentoo-2-ecf86e5aae2f2a37f0f5ad5430f742ad12447eea.tar.bz2
gentoo-2-ecf86e5aae2f2a37f0f5ad5430f742ad12447eea.zip
Version bump for Rails 3.0.11.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.11.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index bc26cad4cf86..a915403ef393 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.98 2011/10/05 17:59:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.99 2011/11/19 11:00:59 graaff Exp $
+
+*activeresource-3.0.11 (19 Nov 2011)
+
+ 19 Nov 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.11.ebuild:
+ Version bump for Rails 3.0.11.
05 Oct 2011; Hans de Graaff <graaff@gentoo.org> -activeresource-3.0.7.ebuild,
-activeresource-3.0.9.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-3.0.11.ebuild b/dev-ruby/activeresource/activeresource-3.0.11.ebuild
new file mode 100644
index 000000000000..9a246eee76a1
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.11.ebuild,v 1.1 2011/11/19 11:00:59 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}