summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-27 05:59:16 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-27 05:59:16 +0000
commited2a6366690752d4fd1c1f02dfbf225888ff30d9 (patch)
tree463a90889486822bd4c19c73daf33bfeeb26da33 /dev-ruby/activerecord
parentCleanup. (diff)
downloadgentoo-2-ed2a6366690752d4fd1c1f02dfbf225888ff30d9.tar.gz
gentoo-2-ed2a6366690752d4fd1c1f02dfbf225888ff30d9.tar.bz2
gentoo-2-ed2a6366690752d4fd1c1f02dfbf225888ff30d9.zip
Cleanup.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.16.ebuild64
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.17.ebuild64
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.10.ebuild70
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.11.ebuild65
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.11.ebuild74
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.12.ebuild74
7 files changed, 7 insertions, 412 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 0d0a674b6df7..433764fae76c 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.240 2013/04/01 14:53:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.241 2013/04/27 05:59:16 graaff Exp $
+
+ 27 Apr 2013; Hans de Graaff <graaff@gentoo.org> -activerecord-2.3.16.ebuild,
+ -activerecord-2.3.17.ebuild, -activerecord-3.1.10.ebuild,
+ -activerecord-3.1.11.ebuild, -activerecord-3.2.11.ebuild,
+ -activerecord-3.2.12.ebuild:
+ Cleanup.
01 Apr 2013; Agostino Sarubbo <ago@gentoo.org> activerecord-2.3.18.ebuild:
Stable for ppc64, wrt bug #462452
diff --git a/dev-ruby/activerecord/activerecord-2.3.16.ebuild b/dev-ruby/activerecord/activerecord-2.3.16.ebuild
deleted file mode 100644
index c13c77c6f072..000000000000
--- a/dev-ruby/activerecord/activerecord-2.3.16.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.16.ebuild,v 1.5 2013/01/31 17:47:28 ago Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3" #sqlite
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
-
-#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
-USE_RUBY=ruby18 \
- ruby_add_rdepend "
- sqlite3? ( dev-ruby/sqlite3 )
- mysql? ( >=dev-ruby/mysql-ruby-2.7 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/rdoc
- =dev-ruby/mocha-0.10*
- )"
-
-all_ruby_prepare() {
- # Custom template not found in package
- sed -i -e '/horo/d' Rakefile || die
-
- # Remove test cases with hash ordering failures.
- sed -i -e '/test_bind_enumerable/,/end/ s:^:#:' test/cases/finder_test.rb || die
- sed -i -e '/test_should_automatically_build_new_associated/,/^ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Make sure we load a compatible version of activesupport for tests.
- sed -i -e '10igem "activesupport", "~>2.3.15"' test/cases/helper.rb || die
-
- # Drop test now broken by security fixes.
- rm test/cases/serialization_test.rb
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-2.3.17.ebuild b/dev-ruby/activerecord/activerecord-2.3.17.ebuild
deleted file mode 100644
index 2c36f1e0c2a9..000000000000
--- a/dev-ruby/activerecord/activerecord-2.3.17.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.17.ebuild,v 1.5 2013/02/24 17:36:25 ago Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3" #sqlite
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
-
-#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
-USE_RUBY=ruby18 \
- ruby_add_rdepend "
- sqlite3? ( dev-ruby/sqlite3 )
- mysql? ( >=dev-ruby/mysql-ruby-2.7 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/rdoc
- =dev-ruby/mocha-0.10*
- )"
-
-all_ruby_prepare() {
- # Custom template not found in package
- sed -i -e '/horo/d' Rakefile || die
-
- # Remove test cases with hash ordering failures.
- sed -i -e '/test_bind_enumerable/,/end/ s:^:#:' test/cases/finder_test.rb || die
- sed -i -e '/test_should_automatically_build_new_associated/,/^ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Make sure we load a compatible version of activesupport for tests.
- sed -i -e '10igem "activesupport", "~>2.3.15"' test/cases/helper.rb || die
-
- # Drop test now broken by security fixes.
- rm test/cases/serialization_test.rb
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.1.10.ebuild b/dev-ruby/activerecord/activerecord-3.1.10.ebuild
deleted file mode 100644
index 98b20a8f5496..000000000000
--- a/dev-ruby/activerecord/activerecord-3.1.10.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.10.ebuild,v 1.2 2013/01/16 00:48:13 zerochaos Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.2.3:2.1
- >=dev-ruby/tzinfo-0.3.29
- sqlite3? ( >=dev-ruby/sqlite3-1.3.4 )
- mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.3
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\|benchmark-ips\)/d' ../Gemfile || die
- sed -i -e '/\(rack-ssl\|thor\)/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
- sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
-
- # Loosen mocha version restriction and skip incompatible tests
- sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
- sed -i -e '/test_a_child_marked_for_destruction_should_not_be_destroyed_twice/,/^ end/ s:^:#:' test/cases/autosave_association_test.rb || die
- sed -i -e '/test_a_parent_marked_for_destruction_should_not_be_destroyed_twice/,/^ end/ s:^:#:' test/cases/autosave_association_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.1.11.ebuild b/dev-ruby/activerecord/activerecord-3.1.11.ebuild
deleted file mode 100644
index b11727a92eef..000000000000
--- a/dev-ruby/activerecord/activerecord-3.1.11.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.11.ebuild,v 1.1 2013/02/11 20:48:05 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.2.3:2.1
- >=dev-ruby/tzinfo-0.3.29
- sqlite3? ( >=dev-ruby/sqlite3-1.3.4 )
- mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.3
- >=dev-ruby/mocha-0.13.0
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\|benchmark-ips\)/d' ../Gemfile || die
- sed -i -e '/\(rack-ssl\|thor\)/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
- sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- TRAVIS=true ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.2.11.ebuild b/dev-ruby/activerecord/activerecord-3.2.11.ebuild
deleted file mode 100644
index 022f27417453..000000000000
--- a/dev-ruby/activerecord/activerecord-3.2.11.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.11.ebuild,v 1.2 2013/01/16 00:48:13 zerochaos Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-3.0.2:3.0
- >=dev-ruby/tzinfo-0.3.29
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- >=dev-ruby/mocha-0.12.1
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *rubyee18)
- # Turn on travis support to avoid tripping bugs in ree18.
- TRAVIS=true ${RUBY} -S rake test_sqlite3
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.2.12.ebuild b/dev-ruby/activerecord/activerecord-3.2.12.ebuild
deleted file mode 100644
index ce6c6cb3ead4..000000000000
--- a/dev-ruby/activerecord/activerecord-3.2.12.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.12.ebuild,v 1.1 2013/02/11 20:12:40 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-3.0.2:3.0
- >=dev-ruby/tzinfo-0.3.29
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- >=dev-ruby/mocha-0.12.1
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *rubyee18)
- # Turn on travis support to avoid tripping bugs in ree18.
- TRAVIS=true ${RUBY} -S rake test_sqlite3
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}