summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-06 20:00:09 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-06 20:00:09 +0000
commit55035c2c05c9d93a240facf7b10d5cbf6e6a8ade (patch)
tree0f23e9095f2742c05660edf2252a14050c94aae1 /dev-ruby/activemodel
parentVersion bump for Rails 4.1.1, security bug 509706. (diff)
downloadgentoo-2-55035c2c05c9d93a240facf7b10d5cbf6e6a8ade.tar.gz
gentoo-2-55035c2c05c9d93a240facf7b10d5cbf6e6a8ade.tar.bz2
gentoo-2-55035c2c05c9d93a240facf7b10d5cbf6e6a8ade.zip
Version bump for Rails 4.1.1, security bug 509706.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-4.1.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 026aadb7e9c4..f3b2f7786da8 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.77 2014/05/06 19:29:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.78 2014/05/06 20:00:09 graaff Exp $
+
+*activemodel-4.1.1 (06 May 2014)
+
+ 06 May 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-4.1.1.ebuild:
+ Version bump for Rails 4.1.1, security bug 509706.
*activemodel-4.0.5 (06 May 2014)
diff --git a/dev-ruby/activemodel/activemodel-4.1.1.ebuild b/dev-ruby/activemodel/activemodel-4.1.1.ebuild
new file mode 100644
index 000000000000..1d1f2c42608c
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.1.ebuild,v 1.1 2014/05/06 20:00:09 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}