summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-18 22:17:12 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-18 22:17:12 +0000
commit5851a393b368b58e579ed7ec776c70970ac742c0 (patch)
tree4f701f3efeeca0c8f859d5ac603a7e25c54192aa /dev-ruby/actionview
parentVersion bump for security bug 520212. (diff)
downloadgentoo-2-5851a393b368b58e579ed7ec776c70970ac742c0.tar.gz
gentoo-2-5851a393b368b58e579ed7ec776c70970ac742c0.tar.bz2
gentoo-2-5851a393b368b58e579ed7ec776c70970ac742c0.zip
Version bump for security bug 520212.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/ChangeLog7
-rw-r--r--dev-ruby/actionview/actionview-4.1.5.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/actionview/ChangeLog b/dev-ruby/actionview/ChangeLog
index 8d4cb75aedab..04a2e857c71f 100644
--- a/dev-ruby/actionview/ChangeLog
+++ b/dev-ruby/actionview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionview
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.7 2014/08/12 21:40:30 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.8 2014/08/18 22:17:12 graaff Exp $
+
+*actionview-4.1.5 (18 Aug 2014)
+
+ 18 Aug 2014; Hans de Graaff <graaff@gentoo.org> +actionview-4.1.5.ebuild:
+ Version bump for security bug 520212.
12 Aug 2014; Anthony G. Basile <blueness@gentoo.org> actionview-4.1.4.ebuild:
Keyword ~ppc and ~ppc64, bug #519170
diff --git a/dev-ruby/actionview/actionview-4.1.5.ebuild b/dev-ruby/actionview/actionview-4.1.5.ebuild
new file mode 100644
index 000000000000..4a8b78b20faa
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/actionview-4.1.5.ebuild,v 1.1 2014/08/18 22:17:12 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1 =dev-ruby/builder-3*
+ >=dev-ruby/erubis-2.7.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
+
+}