summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-20 07:30:36 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-20 07:30:36 +0000
commitab4f8b1f352fbf801cc323c110b4abe2e7447431 (patch)
tree7e43c4c59f6d469882370536690464910eed06b0 /dev-ruby/actionpack
parentRemove razorqt-base category (diff)
downloadgentoo-2-ab4f8b1f352fbf801cc323c110b4abe2e7447431.tar.gz
gentoo-2-ab4f8b1f352fbf801cc323c110b4abe2e7447431.tar.bz2
gentoo-2-ab4f8b1f352fbf801cc323c110b4abe2e7447431.zip
Cleanup of vulnerable versions.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog6
-rw-r--r--dev-ruby/actionpack/actionpack-3.2.20.ebuild77
-rw-r--r--dev-ruby/actionpack/actionpack-4.0.11.ebuild66
-rw-r--r--dev-ruby/actionpack/actionpack-4.1.7.ebuild46
4 files changed, 5 insertions, 190 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 5a95e1021750..0d5216ccf0c2 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.296 2014/11/18 13:45:33 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.297 2014/12/20 07:30:36 graaff Exp $
+
+ 20 Dec 2014; Hans de Graaff <graaff@gentoo.org> -actionpack-3.2.20.ebuild,
+ -actionpack-4.0.11.ebuild, -actionpack-4.1.7.ebuild:
+ Cleanup of vulnerable versions.
18 Nov 2014; Manuel Rüger <mrueg@gentoo.org>
-files/actionpack-2.3.10-i18n-0.4.2.patch,
diff --git a/dev-ruby/actionpack/actionpack-3.2.20.ebuild b/dev-ruby/actionpack/actionpack-3.2.20.ebuild
deleted file mode 100644
index 2a80543eaf5c..000000000000
--- a/dev-ruby/actionpack/actionpack-3.2.20.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.2.20.ebuild,v 1.1 2014/10/31 08:57:35 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-# The default test task tries to test activerecord with SQLite as well.
-RUBY_FAKEGEM_TASK_TEST="test_action_pack"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/rack-cache-1.2
- >=dev-ruby/builder-3.0.0:3
- >=dev-ruby/rack-1.4.5:1.4
- >=dev-ruby/rack-test-0.6.1:0.6
- >=dev-ruby/journey-1.0.4:1.0
- >=dev-ruby/sprockets-2.2.1:2.2
- >=dev-ruby/erubis-2.7.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.13
- dev-ruby/bundler
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/actionmailer-${PV}
- >=dev-ruby/tzinfo-0.3.29:0
- >=dev-ruby/uglifier-1.0.3
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|nokogiri\)/d" ../Gemfile || die
-
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Avoid fragile tests depending on hash ordering
- sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
- sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
- sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
- sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
- sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
-
- # Avoid fragile test that gets more output than it expects.
- sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
-
- # Avoid test broken by security updates in i18n.
- sed -i -e '/test_number_to_i18n_currency/,/end/ s:^:#:' test/template/number_helper_i18n_test.rb || die
-
- # Avoid test that chokes on bad UTF-8.
- sed -i -e '/test_handles_urls_with_bad_encoding/askip "gentoo"' test/dispatch/static_test.rb || die
-}
diff --git a/dev-ruby/actionpack/actionpack-4.0.11.ebuild b/dev-ruby/actionpack/actionpack-4.0.11.ebuild
deleted file mode 100644
index c3bb28f8a5a5..000000000000
--- a/dev-ruby/actionpack/actionpack-4.0.11.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.0.11.ebuild,v 1.1 2014/10/31 08:57:35 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# The default test task tries to test activerecord with SQLite as well.
-RUBY_FAKEGEM_TASK_TEST="test_action_pack"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
- >=dev-ruby/rack-1.5.2:1.5
- >=dev-ruby/rack-test-0.6.2:0.6
- >=dev-ruby/erubis-2.7.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.13
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/actionmailer-${PV}
- dev-ruby/sprockets-rails:2.0
- >=dev-ruby/tzinfo-0.3.37:0
- >=dev-ruby/uglifier-1.0.3
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\)/d" ../Gemfile || die
-
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid fragile test that gets more output than it expects.
- sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
-}
diff --git a/dev-ruby/actionpack/actionpack-4.1.7.ebuild b/dev-ruby/actionpack/actionpack-4.1.7.ebuild
deleted file mode 100644
index f535b1bbb6b0..000000000000
--- a/dev-ruby/actionpack/actionpack-4.1.7.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.1.7.ebuild,v 1.1 2014/10/31 08:57:35 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionview-${PV}
- >=dev-ruby/rack-1.5.2:1.5
- >=dev-ruby/rack-test-0.6.2:0.6"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.14
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/rack-cache-1.2:1.2
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
-}