summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-09-12 05:55:31 +0000
committerHans de Graaff <graaff@gentoo.org>2014-09-12 05:55:31 +0000
commit73692c607b22c9ad25620e49cf4970a172516f5e (patch)
tree113a3998f52fb7fe29f515eb64982cfd55799960 /dev-ruby/actionpack
parentVersion bump. (diff)
downloadgentoo-2-73692c607b22c9ad25620e49cf4970a172516f5e.tar.gz
gentoo-2-73692c607b22c9ad25620e49cf4970a172516f5e.tar.bz2
gentoo-2-73692c607b22c9ad25620e49cf4970a172516f5e.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-4.0.10.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index d14a9136c189..30d4c0eb7b7b 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.290 2014/08/23 07:07:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.291 2014/09/12 05:55:31 graaff Exp $
+
+*actionpack-4.0.10 (12 Sep 2014)
+
+ 12 Sep 2014; Hans de Graaff <graaff@gentoo.org> +actionpack-4.0.10.ebuild:
+ Version bump.
23 Aug 2014; Hans de Graaff <graaff@gentoo.org> -actionpack-4.0.8.ebuild,
-actionpack-4.1.4.ebuild:
diff --git a/dev-ruby/actionpack/actionpack-4.0.10.ebuild b/dev-ruby/actionpack/actionpack-4.0.10.ebuild
new file mode 100644
index 000000000000..15f19534683f
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-4.0.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.0.10.ebuild,v 1.1 2014/09/12 05:55:31 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/rack-1.5.2:1.5
+ >=dev-ruby/rack-test-0.6.2:0.6
+ >=dev-ruby/erubis-2.7.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.13
+ dev-ruby/bundler
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ dev-ruby/sprockets-rails:2.0
+ >=dev-ruby/tzinfo-0.3.37:0
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Add back json in the Gemfile because we dropped some dependencies
+ # earlier that implicitly required it.
+ sed -i -e '$agem "json"' ../Gemfile || die
+
+ # Avoid fragile test that gets more output than it expects.
+ sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
+}