summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-07-09 10:53:03 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-07-09 10:53:03 +0000
commit7d3179b15824dc5e8fd6cd5ae69dce2a0688248c (patch)
tree791641c39684550773313f28f95684a70f5f78e3 /dev-qt/qtdeclarative
parentVersion bump. (diff)
downloadgentoo-2-7d3179b15824dc5e8fd6cd5ae69dce2a0688248c.tar.gz
gentoo-2-7d3179b15824dc5e8fd6cd5ae69dce2a0688248c.tar.bz2
gentoo-2-7d3179b15824dc5e8fd6cd5ae69dce2a0688248c.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/ChangeLog7
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-4.8.5.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-qt/qtdeclarative/ChangeLog b/dev-qt/qtdeclarative/ChangeLog
index 092eff681c1c..b1f74d6dc038 100644
--- a/dev-qt/qtdeclarative/ChangeLog
+++ b/dev-qt/qtdeclarative/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-qt/qtdeclarative
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtdeclarative/ChangeLog,v 1.1 2013/03/02 15:26:48 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtdeclarative/ChangeLog,v 1.2 2013/07/09 10:53:03 pesa Exp $
+
+*qtdeclarative-4.8.5 (09 Jul 2013)
+
+ 09 Jul 2013; Davide Pesavento <pesa@gentoo.org> +qtdeclarative-4.8.5.ebuild:
+ Version bump.
06 Feb 2013; Naohiro Aota <naota@gentoo.org> qt-declarative-4.8.4.ebuild:
Add ~x86-fbsd wrt bug #430072
diff --git a/dev-qt/qtdeclarative/qtdeclarative-4.8.5.ebuild b/dev-qt/qtdeclarative/qtdeclarative-4.8.5.ebuild
new file mode 100644
index 000000000000..b16add97dc5b
--- /dev/null
+++ b/dev-qt/qtdeclarative/qtdeclarative-4.8.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtdeclarative/qtdeclarative-4.8.5.ebuild,v 1.1 2013/07/09 10:53:03 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+IUSE="+accessibility qt3support webkit"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,qt3support=]
+ ~dev-qt/qtgui-${PV}[accessibility=,aqua=,debug=,qt3support=]
+ ~dev-qt/qtopengl-${PV}[aqua=,debug=,qt3support=]
+ ~dev-qt/qtscript-${PV}[aqua=,debug=]
+ ~dev-qt/qtsql-${PV}[aqua=,debug=,qt3support=]
+ ~dev-qt/qtsvg-${PV}[accessibility=,aqua=,debug=]
+ ~dev-qt/qtxmlpatterns-${PV}[aqua=,debug=]
+ qt3support? ( ~dev-qt/qt3support-${PV}[accessibility=,aqua=,debug=] )
+ webkit? ( ~dev-qt/qtwebkit-${PV}[aqua=,debug=] )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/declarative
+ src/imports
+ src/plugins/qmltooling
+ tools/qml
+ tools/qmlplugindump"
+
+ if use webkit; then
+ QT4_TARGET_DIRECTORIES+=" src/3rdparty/webkit/Source/WebKit/qt/declarative"
+ fi
+
+ QT4_EXTRACT_DIRECTORIES="
+ include
+ src
+ tools
+ translations"
+
+ QCONFIG_ADD="declarative"
+ QCONFIG_DEFINE="QT_DECLARATIVE"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ -declarative -no-gtkstyle
+ $(qt_use accessibility)
+ $(qt_use qt3support)
+ $(qt_use webkit)"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ # install private headers
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
+ insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
+ # ran for the 2nd time, need it for the updated headers
+ fix_includes
+ else
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ fi
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} +
+}