summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-24 23:00:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-24 23:00:12 +0000
commitf29c2fc97b688da890de32607dfbcd7d96fb95eb (patch)
tree59f38d137b6e23ce1274fce9120fd9540a208ef2 /dev-python
parentFix pkgconfigdir definition, bug 349558 (diff)
downloadgentoo-2-f29c2fc97b688da890de32607dfbcd7d96fb95eb.tar.gz
gentoo-2-f29c2fc97b688da890de32607dfbcd7d96fb95eb.tar.bz2
gentoo-2-f29c2fc97b688da890de32607dfbcd7d96fb95eb.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha10_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pychm/ChangeLog8
-rw-r--r--dev-python/pychm/pychm-0.8.4.ebuild10
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/pychm/ChangeLog b/dev-python/pychm/ChangeLog
index aba1acf608ac..cf8a5aef74bc 100644
--- a/dev-python/pychm/ChangeLog
+++ b/dev-python/pychm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pychm
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychm/ChangeLog,v 1.11 2008/05/13 07:51:06 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychm/ChangeLog,v 1.12 2010/12/24 23:00:12 arfrever Exp $
+
+ 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pychm-0.8.4.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS.
13 May 2008; Peter Volkov <pva@gentoo.org> pychm-0.8.4.ebuild:
Moving app-doc/chmlib -> dev-libs/chmlib, bug #220741.
diff --git a/dev-python/pychm/pychm-0.8.4.ebuild b/dev-python/pychm/pychm-0.8.4.ebuild
index 88f1e8c7f53e..3b95be21c426 100644
--- a/dev-python/pychm/pychm-0.8.4.ebuild
+++ b/dev-python/pychm/pychm-0.8.4.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychm/pychm-0.8.4.ebuild,v 1.6 2008/05/13 07:51:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychm/pychm-0.8.4.ebuild,v 1.7 2010/12/24 23:00:12 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -14,5 +19,6 @@ KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND="dev-libs/chmlib"
+RDEPEND="${DEPEND}"
PYTHON_MODNAME="chm"