summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-08 07:37:23 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-08 07:37:23 +0000
commitc1ea9df2f4b44833dd747c43d9a3e0dec79d4ee7 (patch)
tree6bc8cc4029ae9a08c61ff4a97b964b30af74e700 /dev-python
parentRemove old. (diff)
downloadgentoo-2-c1ea9df2f4b44833dd747c43d9a3e0dec79d4ee7.tar.gz
gentoo-2-c1ea9df2f4b44833dd747c43d9a3e0dec79d4ee7.tar.bz2
gentoo-2-c1ea9df2f4b44833dd747c43d9a3e0dec79d4ee7.zip
Version bump.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.1.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index 2e12a016e210..4c7868415007 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.65 2012/05/16 02:25:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.66 2012/06/08 07:37:23 radhermit Exp $
+
+*beautifulsoup-4.1.0 (08 Jun 2012)
+
+ 08 Jun 2012; Tim Harder <radhermit@gentoo.org> +beautifulsoup-4.1.0.ebuild:
+ Version bump.
16 May 2012; Jeroen Roovers <jer@gentoo.org> beautifulsoup-3.1.0.1-r1.ebuild:
Marked ~hppa too.
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.1.0.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.1.0.ebuild
new file mode 100644
index 000000000000..c0eb97e32f8a
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.1.0.ebuild,v 1.1 2012/06/08 07:37:23 radhermit Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/
+ http://pypi.python.org/pypi/beautifulsoup4"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/lxml )"
+RDEPEND=""
+
+PYTHON_MODNAME="bs4"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc html
+ fi
+}
+
+src_test() {
+ testing() {
+ cd "build-${PYTHON_ABI}/lib"
+ nosetests --verbosity="${PYTHON_TEST_VERBOSITY}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r doc/build/html/*
+ fi
+}