summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-19 22:08:13 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-19 22:08:13 +0000
commita648374fb4659875f4e984f7bc076adb5a11e7d0 (patch)
treedb3612a51c1092d58e4d0a8b64416454d1be76d2 /dev-python
parentsmall fix0r (diff)
downloadgentoo-2-a648374fb4659875f4e984f7bc076adb5a11e7d0.tar.gz
gentoo-2-a648374fb4659875f4e984f7bc076adb5a11e7d0.tar.bz2
gentoo-2-a648374fb4659875f4e984f7bc076adb5a11e7d0.zip
New version, updated dependencies. Close bug #3891
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygtk/ChangeLog6
-rw-r--r--dev-python/pygtk/files/digest-pygtk-0.6.91
-rw-r--r--dev-python/pygtk/pygtk-0.6.9.ebuild37
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 62805cc9e5fb..f7fa785c3260 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.3 2002/06/13 16:17:12 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.4 2002/06/19 22:08:13 stroke Exp $
+
+*pygtk-0.6.9 (19 Jun 2002)
+ 19 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> pygtk-0.6.9.ebuild
+ New version, updated dependencies. Close bug #3891
*pygtk-1.99.10 (13 Jun 2002)
13 Jun 2002; Spider <spider@gentoo.org> pygtk-1.99.10.ebuild :
diff --git a/dev-python/pygtk/files/digest-pygtk-0.6.9 b/dev-python/pygtk/files/digest-pygtk-0.6.9
new file mode 100644
index 000000000000..4be404d21cfe
--- /dev/null
+++ b/dev-python/pygtk/files/digest-pygtk-0.6.9
@@ -0,0 +1 @@
+MD5 3bd8fd5145884f4aa1e6f373cdc857ba pygtk-0.6.9.tar.gz 388901
diff --git a/dev-python/pygtk/pygtk-0.6.9.ebuild b/dev-python/pygtk/pygtk-0.6.9.ebuild
new file mode 100644
index 000000000000..2b0bbcc2008f
--- /dev/null
+++ b/dev-python/pygtk/pygtk-0.6.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.9.ebuild,v 1.1 2002/06/19 22:08:13 stroke Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ bindings for Python"
+
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/${P}.tar.gz"
+
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+
+DEPEND="virtual/python
+ >=gnome-base/libglade-0.17-r6
+ >=media-libs/imlib-1.8
+ >=media-libs/gdk-pixbuf-0.9.0
+ ( >=x11-libs/gtk+-1.2.10
+ <x11-libs/gtk+-2.0.0 )"
+
+SLOT="1.2"
+src_compile() {
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-libglade-config=/usr/bin/libglade-config \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+# make DESTDIR=${D} install || die
+}
+