summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-20 20:34:34 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-20 20:34:34 +0000
commit9ac902dd888aabf55e3b1ce9f2b10f8189a05712 (patch)
tree7b4bc986a0dbaee2ab0f1688679c8e32538ffccf /dev-python
parentsamba fixes (diff)
downloadgentoo-2-9ac902dd888aabf55e3b1ce9f2b10f8189a05712.tar.gz
gentoo-2-9ac902dd888aabf55e3b1ce9f2b10f8189a05712.tar.bz2
gentoo-2-9ac902dd888aabf55e3b1ce9f2b10f8189a05712.zip
gnome2 fixes
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild20
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild22
2 files changed, 21 insertions, 21 deletions
diff --git a/dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild b/dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild
index 1342ce19cba1..4073546ce813 100644
--- a/dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild
+++ b/dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild,v 1.2 2002/05/23 06:50:10 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.1-r3.ebuild,v 1.3 2002/06/20 20:34:34 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="gnome-python"
@@ -11,23 +11,23 @@ HOMEPAGE="http://www.gnome.org"
DEPEND="virtual/python
=x11-libs/gtk+-1.2*
>=media-libs/imlib-1.9.10-r1
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
- >=gnome-base/libglade-0.17-r1 )
- opengl? ( >=x11-libs/gtkglarea-1.2.2-r1 )"
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ <gnome-base/libglade-1.90.0 )
+ opengl? ( <x11-libs/gtkglarea-1.99.0 )"
src_compile() {
if [ -n "`use gnome`" ]
then
- PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
- --prefix=/usr \
- ${myopts} || die
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
make || die
else
cd ${S}/pygtk
- PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
- --prefix=/usr \
- ${myopts} || die
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
make || die
fi
}
diff --git a/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild b/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild
index e412d4d331fd..92ab0350218f 100644
--- a/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild
+++ b/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild,v 1.2 2002/05/23 06:50:10 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild,v 1.3 2002/06/20 20:34:34 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="gnome-python"
@@ -11,24 +11,24 @@ HOMEPAGE="http://www.gnome.org"
DEPEND="virtual/python
=x11-libs/gtk+-1.2*
>=media-libs/imlib-1.9.10-r1
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
- >=gnome-base/libglade-0.17-r1
- >=gnome-base/control-center-1.4.0.4 )
- opengl? ( >=x11-libs/gtkglarea-1.2.2-r1 )"
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ <gnome-base/libglade-1.90.0
+ <gnome-base/control-center-1.90.0 )
+ opengl? ( <x11-libs/gtkglarea-1.99.0 )"
src_compile() {
if [ -n "`use gnome`" ]
then
- PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
- --prefix=/usr \
- ${myopts} || die
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
make CFLAGS="${CFLAGS} \`gnome-config capplet --cflags\`" || die
else
cd ${S}/pygtk
- PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
- --prefix=/usr \
- ${myopts} || die
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
make || die
fi
}