summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-18 18:01:51 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-18 18:01:51 +0000
commit82f0f72e16e6a1064c5e92ad755ac2e49359fb78 (patch)
treee86c5bd320737829fcc39fc89cf55629bd632bcb /dev-python
parentVersion bump wrt bug 480498, credit to Didier Barvaux <didier-bugzillagentoo@... (diff)
downloadgentoo-2-82f0f72e16e6a1064c5e92ad755ac2e49359fb78.tar.gz
gentoo-2-82f0f72e16e6a1064c5e92ad755ac2e49359fb78.tar.bz2
gentoo-2-82f0f72e16e6a1064c5e92ad755ac2e49359fb78.zip
version bump, fixes #474628
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jedi/ChangeLog7
-rw-r--r--dev-python/jedi/jedi-0.7.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/jedi/ChangeLog b/dev-python/jedi/ChangeLog
index f565f92099f8..645e704b732a 100644
--- a/dev-python/jedi/ChangeLog
+++ b/dev-python/jedi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jedi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.3 2013/06/25 12:50:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.4 2013/08/18 18:01:51 hasufell Exp $
+
+*jedi-0.7.0 (18 Aug 2013)
+
+ 18 Aug 2013; Julian Ospald <hasufell@gentoo.org> +jedi-0.7.0.ebuild:
+ version bump, fixes #474628
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> jedi-0.6.0.ebuild:
Stable for amd64, wrt bug #474186
diff --git a/dev-python/jedi/jedi-0.7.0.ebuild b/dev-python/jedi/jedi-0.7.0.ebuild
new file mode 100644
index 000000000000..840bb5a0084e
--- /dev/null
+++ b/dev-python/jedi/jedi-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/jedi-0.7.0.ebuild,v 1.1 2013/08/18 18:01:51 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="Awesome autocompletion library for python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="mirror://pypi/j/jedi/jedi-${MY_PV}.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${P}-html-docs.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="app-arch/xz-utils
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dohtml -r "${WORKDIR}"/html/*
+ distutils-r1_python_install_all
+}