summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-15 13:59:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-15 13:59:24 +0000
commit7d9b703c4c46155d1b5be7d0f29519d5f05167d4 (patch)
tree7bc0b067fb62b8b6527cb47e2b0faad9a0754bf8 /dev-python
parentkeyworded for linux prefix (diff)
downloadgentoo-2-7d9b703c4c46155d1b5be7d0f29519d5f05167d4.tar.gz
gentoo-2-7d9b703c4c46155d1b5be7d0f29519d5f05167d4.tar.bz2
gentoo-2-7d9b703c4c46155d1b5be7d0f29519d5f05167d4.zip
Use python_clean_installation_image() instead of manually deleting .la files.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/python-poppler/python-poppler-0.12.1.ebuild b/dev-python/python-poppler/python-poppler-0.12.1.ebuild
index 3028bb099f9c..0507aa7a437c 100644
--- a/dev-python/python-poppler/python-poppler-0.12.1.ebuild
+++ b/dev-python/python-poppler/python-poppler-0.12.1.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1.ebuild,v 1.6 2010/05/18 13:00:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1.ebuild,v 1.7 2010/06/15 13:59:24 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2:2.6"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
inherit libtool python
DESCRIPTION="Python bindings to the Poppler PDF library"
-SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
HOMEPAGE="http://launchpad.net/poppler-python"
+SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="examples"
-S=${WORKDIR}/pypoppler-${PV}
+S="${WORKDIR}/pypoppler-${PV}"
RDEPEND=">=app-text/poppler-0.12.3-r3[cairo]
+ >=dev-python/pycairo-1.8.4
dev-python/pygobject:2
- dev-python/pygtk:2
- >=dev-python/pycairo-1.8.4"
+ dev-python/pygtk:2"
DEPEND="${RDEPEND}"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3*"
-
src_prepare() {
elibtoolize
python_copy_sources
@@ -35,10 +34,12 @@ src_prepare() {
src_install() {
python_src_install
- find "${D}" -name '*.la' -type f -exec rm -f '{}' ';' || die "Removing .la files failed"
- dodoc NEWS || die
+ python_clean_installation_image
+
+ dodoc NEWS || die "dodoc failed"
+
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins demo/demo-poppler.py || die
+ doins demo/demo-poppler.py || die "doins failed"
fi
}