summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-13 17:36:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-13 17:36:03 +0000
commit74123ba9f4c15a7e78b068cbe57cbf02d9f2b942 (patch)
tree127f2283d2477f1afc651c703808b1b8b4471e95 /dev-python
parentx86 stable per bug 359469 (diff)
downloadgentoo-2-74123ba9f4c15a7e78b068cbe57cbf02d9f2b942.tar.gz
gentoo-2-74123ba9f4c15a7e78b068cbe57cbf02d9f2b942.tar.bz2
gentoo-2-74123ba9f4c15a7e78b068cbe57cbf02d9f2b942.zip
Version bump.
(Portage version: 2.2.0_alpha29_p18/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/ChangeLog8
-rw-r--r--dev-python/dulwich/dulwich-0.7.1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index b99a3cc857e1..4df78724b7ab 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.25 2011/04/08 22:43:16 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.26 2011/04/13 17:36:03 arfrever Exp $
+
+*dulwich-0.7.1 (13 Apr 2011)
+
+ 13 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +dulwich-0.7.1.ebuild:
+ Version bump.
08 Apr 2011; Thomas Kahle <tomka@gentoo.org> dulwich-0.7.0.ebuild:
x86 stable per bug 360343
diff --git a/dev-python/dulwich/dulwich-0.7.1.ebuild b/dev-python/dulwich/dulwich-0.7.1.ebuild
new file mode 100644
index 000000000000..7887e90181d4
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.7.1.ebuild,v 1.1 2011/04/13 17:36:03 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ test? ( || ( dev-lang/python:2.7 dev-python/unittest2 dev-python/testtools ) )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
+}
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _diff_tree _objects _pack; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}