summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-05-09 22:12:36 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-05-09 22:12:36 +0000
commit5fd19413f5e5c6e28474ecb8b3cf0a07f308257f (patch)
tree600fe92e44c396f70b2426f39b104b0f4ca0ad9f /dev-python
parentRevision bump adding fixes for gcc-5.1, bug 548094 (diff)
downloadgentoo-2-5fd19413f5e5c6e28474ecb8b3cf0a07f308257f.tar.gz
gentoo-2-5fd19413f5e5c6e28474ecb8b3cf0a07f308257f.tar.bz2
gentoo-2-5fd19413f5e5c6e28474ecb8b3cf0a07f308257f.zip
add version 1.2.2
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/docker-py/ChangeLog7
-rw-r--r--dev-python/docker-py/docker-py-1.2.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/docker-py/ChangeLog b/dev-python/docker-py/ChangeLog
index 219fb5092f2e..1bc3e07ce69f 100644
--- a/dev-python/docker-py/ChangeLog
+++ b/dev-python/docker-py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/docker-py
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docker-py/ChangeLog,v 1.26 2015/05/06 05:51:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docker-py/ChangeLog,v 1.27 2015/05/09 22:12:36 alunduil Exp $
+
+*docker-py-1.2.2 (09 May 2015)
+
+ 09 May 2015; Alex Brandt <alunduil@gentoo.org> +docker-py-1.2.2.ebuild:
+ add version 1.2.2
06 May 2015; Justin Lecher <jlec@gentoo.org> -docker-py-1.1.0-r1.ebuild,
docker-py-0.7.1.ebuild, docker-py-1.1.0-r2.ebuild, docker-py-1.2.1.ebuild,
diff --git a/dev-python/docker-py/docker-py-1.2.2.ebuild b/dev-python/docker-py/docker-py-1.2.2.ebuild
new file mode 100644
index 000000000000..539a956fb324
--- /dev/null
+++ b/dev-python/docker-py/docker-py-1.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docker-py/docker-py-1.2.2.ebuild,v 1.1 2015/05/09 22:12:36 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/mkdocs-0.9[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/mock-1.0.1[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/websocket-client-0.11.0[${PYTHON_USEDEP}]' python2_7)
+"
+
+python_compile_all() {
+ if use doc; then
+ mkdocs build || die "docs failed to build"
+ fi
+}
+
+python_test() {
+ "${PYTHON}" tests/test.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( site/. )
+
+ distutils-r1_python_install_all
+}