summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2015-05-09 07:04:51 +0000
committerJohann Schmitz <ercpe@gentoo.org>2015-05-09 07:04:51 +0000
commit4d5e0f9cc4f38651d785b451eea381c7ee53a17c (patch)
treecc029f013e4d92c5e11e66e4f33bcf4af0c6449c /dev-python
parentremove entry masking media-video/vlc from 13.0/package.use.stable.mask (diff)
downloadgentoo-2-4d5e0f9cc4f38651d785b451eea381c7ee53a17c.tar.gz
gentoo-2-4d5e0f9cc4f38651d785b451eea381c7ee53a17c.tar.bz2
gentoo-2-4d5e0f9cc4f38651d785b451eea381c7ee53a17c.zip
Version bump of django-two-factor-auth to 1.2.0
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-two-factor-auth/ChangeLog8
-rw-r--r--dev-python/django-two-factor-auth/django-two-factor-auth-1.2.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/django-two-factor-auth/ChangeLog b/dev-python/django-two-factor-auth/ChangeLog
index c0fd7aba99ad..5714fe8a7d7f 100644
--- a/dev-python/django-two-factor-auth/ChangeLog
+++ b/dev-python/django-two-factor-auth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-two-factor-auth
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-two-factor-auth/ChangeLog,v 1.5 2015/04/08 08:05:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-two-factor-auth/ChangeLog,v 1.6 2015/05/09 07:04:51 ercpe Exp $
+
+*django-two-factor-auth-1.2.0 (09 May 2015)
+
+ 09 May 2015; Johann Schmitz <ercpe@gentoo.org>
+ +django-two-factor-auth-1.2.0.ebuild:
+ Version bump of django-two-factor-auth to 1.2.0
08 Apr 2015; Michał Górny <mgorny@gentoo.org>
django-two-factor-auth-1.1.1.ebuild:
diff --git a/dev-python/django-two-factor-auth/django-two-factor-auth-1.2.0.ebuild b/dev-python/django-two-factor-auth/django-two-factor-auth-1.2.0.ebuild
new file mode 100644
index 000000000000..6dee329c5861
--- /dev/null
+++ b/dev-python/django-two-factor-auth/django-two-factor-auth-1.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-two-factor-auth/django-two-factor-auth-1.2.0.ebuild,v 1.1 2015/05/09 07:04:51 ercpe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="User-friendly Two-Factor Authentication for Django"
+HOMEPAGE="https://github.com/Bouke/django-two-factor-auth"
+SRC_URI="https://github.com/Bouke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test yubikey"
+
+CDEPEND=">=dev-python/django-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-otp-0.2.0[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/twilio[${PYTHON_USEDEP}]
+ yubikey? ( dev-python/django-otp-yubikey[${PYTHON_USEDEP}] )
+ "
+
+RDEPEND="${CDEPEND}"
+DEPEND="test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ )"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i "/'qrcode/s/^/#/" setup.py || die
+}
+
+python_test() {
+ emake test
+}