summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-12-12 17:44:24 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-12-12 17:44:24 +0000
commit28bfc803655dd4bd2d51263ec8abda51af67c006 (patch)
treec1f1ce084c6de017bc978e78dd144963d162e7c2 /dev-python
parentRemove old. (diff)
downloadgentoo-2-28bfc803655dd4bd2d51263ec8abda51af67c006.tar.gz
gentoo-2-28bfc803655dd4bd2d51263ec8abda51af67c006.tar.bz2
gentoo-2-28bfc803655dd4bd2d51263ec8abda51af67c006.zip
Remove old.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shiboken/ChangeLog5
-rw-r--r--dev-python/shiboken/shiboken-1.1.1.ebuild92
2 files changed, 4 insertions, 93 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 80eb78d48365..ca4549e1a80b 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.37 2012/11/21 11:27:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.38 2012/12/12 17:44:24 pesa Exp $
+
+ 12 Dec 2012; Davide Pesavento <pesa@gentoo.org> -shiboken-1.1.1.ebuild:
+ Remove old.
21 Nov 2012; Agostino Sarubbo <ago@gentoo.org> shiboken-1.1.2.ebuild:
Stable for x86, wrt bug #438390
diff --git a/dev-python/shiboken/shiboken-1.1.1.ebuild b/dev-python/shiboken/shiboken-1.1.1.ebuild
deleted file mode 100644
index f57801537c61..000000000000
--- a/dev-python/shiboken/shiboken-1.1.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.1.ebuild,v 1.7 2012/10/17 06:39:07 kensington Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6 3:3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.1 3.3 *-jython 2.7-pypy-*"
-
-inherit multilib cmake-utils python
-
-DESCRIPTION="A tool for creating Python bindings for C++ libraries"
-HOMEPAGE="http://www.pyside.org/"
-SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-libs/libxml2-2.6.32
- >=dev-libs/libxslt-1.1.19
- >=x11-libs/qt-core-4.7.0:4
- >=x11-libs/qt-xmlpatterns-4.7.0:4
- !dev-python/apiextractor
- !dev-python/generatorrunner
-"
-DEPEND="${RDEPEND}
- test? (
- >=x11-libs/qt-gui-4.7.0:4
- >=x11-libs/qt-test-4.7.0:4
- )"
-
-DOCS=( AUTHORS ChangeLog )
-
-src_prepare() {
- # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
- # caused by the usage of a different version suffix with python >= 3.2
- sed -i -e "/get_config_var('SOABI')/d" \
- cmake/Modules/FindPython3InterpWithDebug.cmake || die
- if use prefix; then
- cp "${FILESDIR}"/rpath.cmake .
- sed \
- -i '1iinclude(rpath.cmake)' \
- CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- configuration() {
- local mycmakeargs=(
- -DPYTHON_EXECUTABLE="$(PYTHON -a)"
- -DPYTHON_SUFFIX="-python${PYTHON_ABI}"
- $(cmake-utils_use_build test TESTS)
- )
-
- if [[ $(python_get_version -l --major) == 3 ]]; then
- mycmakeargs+=(
- -DUSE_PYTHON3=ON
- -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON3_LIBRARY="$(python_get_library)"
- )
- fi
-
- CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_configure
- }
- python_execute_function configuration
-}
-
-src_compile() {
- compilation() {
- CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_make
- }
- python_execute_function compilation
-}
-
-src_test() {
- testing() {
- CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_test
- }
- python_execute_function testing
-}
-
-src_install() {
- installation() {
- CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_install
- mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-python${PYTHON_ABI}}.pc || die
- }
- python_execute_function installation
-}