summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-16 15:01:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-16 15:01:25 +0000
commit2406682d1ee9ffeb6eef908d40f464d48dce8d65 (patch)
tree42d17d176956c517220cab7f97b466c14db8b9c4 /dev-python
parentAdd eautoreconf; fixes bug #510002, reported by Pacho. (diff)
downloadgentoo-2-2406682d1ee9ffeb6eef908d40f464d48dce8d65.tar.gz
gentoo-2-2406682d1ee9ffeb6eef908d40f464d48dce8d65.tar.bz2
gentoo-2-2406682d1ee9ffeb6eef908d40f464d48dce8d65.zip
test phase again updated subject to a bump of nose with the result that pypy is no longer skipped
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cherrypy/ChangeLog6
-rw-r--r--dev-python/cherrypy/cherrypy-3.3.0.ebuild24
2 files changed, 17 insertions, 13 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index 275549ba4e33..3fb45a6800f1 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.63 2014/05/16 04:25:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.64 2014/05/16 15:01:25 idella4 Exp $
+
+ 16 May 2014; Ian Delaney <idella4@gentoo.org> cherrypy-3.3.0.ebuild:
+ test phase again updated subject to a bump of nose with the result that pypy
+ is no longer skipped
16 May 2014; Ian Delaney <idella4@gentoo.org> cherrypy-3.3.0.ebuild:
update test phase
diff --git a/dev-python/cherrypy/cherrypy-3.3.0.ebuild b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
index 7434eb219eae..250761a31f6a 100644
--- a/dev-python/cherrypy/cherrypy-3.3.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.2 2014/05/16 04:25:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.3 2014/05/16 15:01:25 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-ma
IUSE="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? ( >=dev-python/nose-1.3.3[${PYTHON_USEDEP}] )"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
@@ -34,20 +34,20 @@ python_prepare_all() {
}
python_test() {
+ # suite requires current latest nose-1.3.3
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1308
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1306
local exclude=(
- # https://bitbucket.org/cherrypy/cherrypy/issue/1306
- -e test_session
-
- # https://bitbucket.org/cherrypy/cherrypy/issue/1308
- -e test_file_stream
-
- # https://bitbucket.org/cherrypy/cherrypy/issue/1315
- -e test_HTTP11_pipelining
+ -e test_file_stream -e test_4_File_deletion -e test_3_Redirect
+ -e test_2_File_Concurrency -e test_0_Session -e testStatic
)
# This really doesn't sit well with multiprocessing
- # https://github.com/nose-devs/nose/issues/808
- if ! [[ "${EPYTHON}" == pypy ]]; then
+ # The issue 1306 tells us some tests are subject to the deleterious effects of
+ # the 'race condition'. Both the issues are unresolved / open
+ if [[ "${EPYTHON}" == pypy ]]; then
+ nosetests "${exclude[@]}" -I test_logging.py < /dev/tty || die "Testing failed with${EPYTHON}"
+ else
nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
fi
}