summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-25 21:01:39 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-25 21:01:39 +0000
commit3bfc2e34e9a5ae8d1da0472aa6103137403a9cd0 (patch)
treebbee2dba812f6b3f37bddf0039244dee903ba9e7 /dev-python/zsi
parentForce python2 since the build system is broken on python3 (diff)
downloadgentoo-2-3bfc2e34e9a5ae8d1da0472aa6103137403a9cd0.tar.gz
gentoo-2-3bfc2e34e9a5ae8d1da0472aa6103137403a9cd0.tar.bz2
gentoo-2-3bfc2e34e9a5ae8d1da0472aa6103137403a9cd0.zip
Force python2 since the build system is broken on python3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/zsi')
-rw-r--r--dev-python/zsi/ChangeLog8
-rw-r--r--dev-python/zsi/zsi-2.0.ebuild10
-rw-r--r--dev-python/zsi/zsi-2.1_alpha1.ebuild10
3 files changed, 21 insertions, 7 deletions
diff --git a/dev-python/zsi/ChangeLog b/dev-python/zsi/ChangeLog
index 8c68266d5664..ad1ee44867ea 100644
--- a/dev-python/zsi/ChangeLog
+++ b/dev-python/zsi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/zsi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/ChangeLog,v 1.11 2009/05/23 15:51:17 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/ChangeLog,v 1.12 2010/05/25 21:01:39 angelos Exp $
+
+ 25 May 2010; Christoph Mende <angelos@gentoo.org> zsi-2.0.ebuild,
+ zsi-2.1_alpha1.ebuild:
+ Force python2 since the build system is broken on python3
*zsi-2.1_alpha1 (23 May 2009)
diff --git a/dev-python/zsi/zsi-2.0.ebuild b/dev-python/zsi/zsi-2.0.ebuild
index b433e23dc76f..aef44578f533 100644
--- a/dev-python/zsi/zsi-2.0.ebuild
+++ b/dev-python/zsi/zsi-2.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.0.ebuild,v 1.8 2009/03/13 16:26:36 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.0.ebuild,v 1.9 2010/05/25 21:01:39 angelos Exp $
+
+PYTHON_DEPEND="2:2.4"
inherit distutils
@@ -26,6 +28,10 @@ DEPEND=">=dev-python/pyxml-0.8.3
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME=${MY_PN}
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
diff --git a/dev-python/zsi/zsi-2.1_alpha1.ebuild b/dev-python/zsi/zsi-2.1_alpha1.ebuild
index 04f5570efbeb..af29e53b9217 100644
--- a/dev-python/zsi/zsi-2.1_alpha1.ebuild
+++ b/dev-python/zsi/zsi-2.1_alpha1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.1_alpha1.ebuild,v 1.2 2009/05/23 16:00:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zsi/zsi-2.1_alpha1.ebuild,v 1.3 2010/05/25 21:01:39 angelos Exp $
EAPI=2
-NEED_PYTHON=2.4
+PYTHON_DEPEND="2:2.4"
inherit distutils
MY_PN=ZSI
@@ -26,6 +26,10 @@ DEPEND=">=dev-python/pyxml-0.8.3
S=${WORKDIR}/${MY_P}
PYTHON_MODNAME=${MY_PN}
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
if ! use twisted; then
sed -i \