summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-25 05:09:43 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-25 05:09:43 +0000
commit28fb9af93ad4e41b57ed7071125655f4a6eca293 (patch)
tree253292aed909753d47aadecc2679a141dad107f4 /dev-python/xmltodict
parentVersion bump. (diff)
downloadgentoo-2-28fb9af93ad4e41b57ed7071125655f4a6eca293.tar.gz
gentoo-2-28fb9af93ad4e41b57ed7071125655f4a6eca293.tar.bz2
gentoo-2-28fb9af93ad4e41b57ed7071125655f4a6eca293.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/ChangeLog7
-rw-r--r--dev-python/xmltodict/xmltodict-0.9.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/xmltodict/ChangeLog b/dev-python/xmltodict/ChangeLog
index 5a43e3659863..7daa89bd32d5 100644
--- a/dev-python/xmltodict/ChangeLog
+++ b/dev-python/xmltodict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xmltodict
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.8 2014/04/16 08:20:10 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.9 2014/04/25 05:09:43 radhermit Exp $
+
+*xmltodict-0.9.0 (25 Apr 2014)
+
+ 25 Apr 2014; Tim Harder <radhermit@gentoo.org> +xmltodict-0.9.0.ebuild:
+ Version bump.
16 Apr 2014; Ian Delaney <idella4@gentoo.org> xmltodict-0.8.7.ebuild:
add pypy support
diff --git a/dev-python/xmltodict/xmltodict-0.9.0.ebuild b/dev-python/xmltodict/xmltodict-0.9.0.ebuild
new file mode 100644
index 000000000000..0afc17b7616e
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/xmltodict-0.9.0.ebuild,v 1.1 2014/04/25 05:09:43 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # avoid setuptools sandbox issues, bug #489726
+ sed -i '/setup_requires/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}