summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-30 09:59:15 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-30 09:59:15 +0000
commitc9649ab4264ac9e7bef8c09a11d322261cd69176 (patch)
treee148791c44a6190a7081a059dee3e462a4c62dc9 /dev-python/xlrd
parentOne more reference, drop old (diff)
downloadgentoo-2-c9649ab4264ac9e7bef8c09a11d322261cd69176.tar.gz
gentoo-2-c9649ab4264ac9e7bef8c09a11d322261cd69176.tar.bz2
gentoo-2-c9649ab4264ac9e7bef8c09a11d322261cd69176.zip
drop py2.6 pypy2.0 add py3.4, update homepage, remove redundant IUSE flags due to missing source content, add test phase, patch by fau, fixes bug #509824
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/ChangeLog6
-rw-r--r--dev-python/xlrd/xlrd-0.9.3.ebuild32
2 files changed, 15 insertions, 23 deletions
diff --git a/dev-python/xlrd/ChangeLog b/dev-python/xlrd/ChangeLog
index c86cfde3d55c..b4141596b97c 100644
--- a/dev-python/xlrd/ChangeLog
+++ b/dev-python/xlrd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/xlrd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.24 2014/05/07 06:43:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.25 2014/06/30 09:59:15 idella4 Exp $
+
+ 30 Jun 2014; Ian Delaney <idella4@gentoo.org> xlrd-0.9.3.ebuild:
+ drop py2.6 pypy2.0 add py3.4, update homepage, remove redundant IUSE flags due
+ to missing source content, add test phase, patch by fau, fixes bug #509824
*xlrd-0.9.3 (07 May 2014)
diff --git a/dev-python/xlrd/xlrd-0.9.3.ebuild b/dev-python/xlrd/xlrd-0.9.3.ebuild
index b39beebb9bae..8d6f84b3a6f5 100644
--- a/dev-python/xlrd/xlrd-0.9.3.ebuild
+++ b/dev-python/xlrd/xlrd-0.9.3.ebuild
@@ -1,40 +1,28 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/xlrd-0.9.3.ebuild,v 1.1 2014/05/07 06:43:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/xlrd-0.9.3.ebuild,v 1.2 2014/06/30 09:59:15 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
inherit distutils-r1
DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
-HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+HOMEPAGE="http://www.python-excel.org/
+ https://github.com/python-excel/xlrd/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE="doc examples"
-DEPEND=""
-RDEPEND=""
+python_prepare_all() {
+ # Remove this if examples get reintroduced
+ sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
-src_prepare() {
- distutils-r1_src_prepare
- # add shebang to runxlrd.py
- sed -i -e '1i#!/usr/bin/encompdoc.html xlrd.htmlv python' scripts/runxlrd.py || die
+ distutils-r1_python_prepare_all
}
-python_install_all() {
- distutils-r1_python_install_all
-
- if use doc; then
- dohtml ${PN}/doc/{compdoc.html,xlrd.html}
- fi
-
- if use examples; then
- docompress -x usr/share/doc/${P}/examples/
- insinto usr/share/doc/${P}/examples
- doins ${PN}/examples/*
- fi
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
}