summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-08-02 19:46:07 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-08-02 19:46:07 +0000
commitade6ee39dce7f15610ecbce9950a064d409637d2 (patch)
tree59768c7bb67ca707c488f65f2965bf4165b056e9 /dev-python/wxpython
parentfc-cache -f breaks the font eclass, according to foser. (Manifest recommit) (diff)
downloadgentoo-2-ade6ee39dce7f15610ecbce9950a064d409637d2.tar.gz
gentoo-2-ade6ee39dce7f15610ecbce9950a064d409637d2.tar.bz2
gentoo-2-ade6ee39dce7f15610ecbce9950a064d409637d2.zip
Added missing controls2.py.patch
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/Manifest3
-rw-r--r--dev-python/wxpython/files/controsl2.py.patch37
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index acde59fbc147..b43999728f3f 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.5 2004/08/02 14:47:46 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.6 2004/08/02 19:46:07 pythonhead Exp $
+
+ 02 Aug 2004; Rob Cakebread <pythonhead@gentoo.org>
+ +files/controsl2.py.patch:
+ Added missing controls2.py.patch
02 Aug 2004; Ferris McCormick <fmccor@gentoo.org> wxpython-2.4.2.4.ebuild:
Stable for sparc. This version runs fine, and the previous stable
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index 6e0a87753bdf..04345db8a250 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -1,8 +1,9 @@
-MD5 42342c0a0864267d9ae0b7c704676d17 ChangeLog 7386
MD5 3b06f1e87549af51d78bb7bfa33728b5 metadata.xml 182
MD5 e11efdbd81a393a1733db932d753cc47 wxpython-2.4.0.7.ebuild 3004
MD5 ce88e056727f5cdfa54452ad71324283 wxpython-2.4.1.2.ebuild 2368
+MD5 42342c0a0864267d9ae0b7c704676d17 ChangeLog 7386
MD5 222b95f1da61243305a8605ae9c191c5 wxpython-2.4.2.4.ebuild 3357
MD5 88f72c81ee2c594876b3bddc9e14bb72 files/digest-wxpython-2.4.0.7 73
MD5 ce3003c042f7c8fe4700193e357ad2ad files/digest-wxpython-2.4.1.2 73
MD5 d1efabd4c6bcd5edd9e61ca070e20ff0 files/digest-wxpython-2.4.2.4 73
+MD5 37295268538eed996c33360b0af9e529 files/controsl2.py.patch 2203
diff --git a/dev-python/wxpython/files/controsl2.py.patch b/dev-python/wxpython/files/controsl2.py.patch
new file mode 100644
index 000000000000..bf5ac197f454
--- /dev/null
+++ b/dev-python/wxpython/files/controsl2.py.patch
@@ -0,0 +1,37 @@
+diff -urN wxPythonSrc-2.4.1.2/wxPython/src/gtk/controls2.py wxPythonSrc-2.4.1.2-modified/wxPython/src/gtk/controls2.py
+--- wxPythonSrc-2.4.1.2/wxPython/src/gtk/controls2.py 2003-06-12 18:25:30.000000000 -0500
++++ wxPythonSrc-2.4.1.2-modified/wxPython/src/gtk/controls2.py 2003-07-10 18:19:51.000000000 -0500
+@@ -642,7 +642,7 @@
+ return "<%s.%s instance; proxy of C++ wxListCtrl instance at %s>" % (self.__class__.__module__, self.__class__.__name__, self.this)
+
+ def GetColumn(self, *_args, **_kwargs):
+- val = ontrols2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
++ val = controls2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
+ if val is not None: val.thisown = 1
+ return val
+
+diff -urN wxPythonSrc-2.4.1.2/wxPython/src/mac/controls2.py wxPythonSrc-2.4.1.2-modified/wxPython/src/mac/controls2.py
+--- wxPythonSrc-2.4.1.2/wxPython/src/mac/controls2.py 2003-05-16 13:36:52.000000000 -0500
++++ wxPythonSrc-2.4.1.2-modified/wxPython/src/mac/controls2.py 2003-07-10 18:20:41.000000000 -0500
+@@ -642,7 +642,7 @@
+ return "<%s.%s instance; proxy of C++ wxListCtrl instance at %s>" % (self.__class__.__module__, self.__class__.__name__, self.this)
+
+ def GetColumn(self, *_args, **_kwargs):
+- val = ontrols2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
++ val = controls2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
+ if val is not None: val.thisown = 1
+ return val
+
+diff -urN wxPythonSrc-2.4.1.2/wxPython/src/msw/controls2.py wxPythonSrc-2.4.1.2-modified/wxPython/src/msw/controls2.py
+--- wxPythonSrc-2.4.1.2/wxPython/src/msw/controls2.py 2003-05-07 14:29:04.000000000 -0500
++++ wxPythonSrc-2.4.1.2-modified/wxPython/src/msw/controls2.py 2003-07-10 18:20:11.000000000 -0500
+@@ -645,7 +645,7 @@
+ return "<%s.%s instance; proxy of C++ wxListCtrl instance at %s>" % (self.__class__.__module__, self.__class__.__name__, self.this)
+
+ def GetColumn(self, *_args, **_kwargs):
+- val = ontrols2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
++ val = controls2c.wxListCtrl_GetColumn(self, *_args, **_kwargs)
+ if val is not None: val.thisown = 1
+ return val
+
+