summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-16 11:15:45 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-16 11:15:45 +0000
commit3747f4cbd59c41893d8df63bb45d97c942eac8a9 (patch)
tree9e380429e7a7c30e700552dca7b378412973b3ca /dev-python/ws4py
parentMasking system-ffmpeg on media-libs/avidemux-core until it compiles and works. (diff)
downloadgentoo-2-3747f4cbd59c41893d8df63bb45d97c942eac8a9.tar.gz
gentoo-2-3747f4cbd59c41893d8df63bb45d97c942eac8a9.tar.bz2
gentoo-2-3747f4cbd59c41893d8df63bb45d97c942eac8a9.zip
migration revbump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/ChangeLog7
-rw-r--r--dev-python/ws4py/ws4py-0.2.4-r1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/ws4py/ChangeLog b/dev-python/ws4py/ChangeLog
index 496a6c65183c..905898d96f68 100644
--- a/dev-python/ws4py/ChangeLog
+++ b/dev-python/ws4py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ws4py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.8 2013/01/11 15:50:38 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.9 2013/03/16 11:15:45 idella4 Exp $
+
+*ws4py-0.2.4-r1 (16 Mar 2013)
+
+ 16 Mar 2013; Ian Delaney <idella4@gentoo.org> +ws4py-0.2.4-r1.ebuild:
+ migration revbump
*ws4py-0.2.4 (11 Jan 2013)
diff --git a/dev-python/ws4py/ws4py-0.2.4-r1.ebuild b/dev-python/ws4py/ws4py-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..7a0ac1a16b52
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.2.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.2.4-r1.ebuild,v 1.1 2013/03/16 11:15:45 idella4 Exp $
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+
+RDEPEND=""
+DEPEND="test? (
+ ${RDEPEND}
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ >=dev-python/cherrypy-3.2.0[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2-cherrypy_test.patch )
+
+python_test() {
+ esetup.py test || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}