summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2008-12-06 23:20:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2008-12-06 23:20:30 +0000
commit8169df83ece75ed6ba7b68b6a4971c23442c6563 (patch)
tree755b259ff404eba4fb93e32a77649d48e0d533ed /dev-python/werkzeug
parentVersion bump with current CVS version. (diff)
downloadgentoo-2-8169df83ece75ed6ba7b68b6a4971c23442c6563.tar.gz
gentoo-2-8169df83ece75ed6ba7b68b6a4971c23442c6563.tar.bz2
gentoo-2-8169df83ece75ed6ba7b68b6a4971c23442c6563.zip
Bumping to 0.4, closing 249442
(Portage version: 2.2_rc17/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/ChangeLog7
-rw-r--r--dev-python/werkzeug/werkzeug-0.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index 559447fc6610..408f3d3909df 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.4 2008/08/04 12:02:26 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.5 2008/12/06 23:20:30 patrick Exp $
+
+*werkzeug-0.4 (06 Dec 2008)
+
+ 06 Dec 2008; Patrick Lauer <patrick@gentoo.org> +werkzeug-0.4.ebuild:
+ Bumping to 0.4, closing 249442
*werkzeug-0.3.1-r1 (04 Aug 2008)
diff --git a/dev-python/werkzeug/werkzeug-0.4.ebuild b/dev-python/werkzeug/werkzeug-0.4.ebuild
new file mode 100644
index 000000000000..60a97c4cdec7
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.4.ebuild,v 1.1 2008/12/06 23:20:30 patrick Exp $
+
+NEED_PYTHON="2.4"
+
+inherit distutils
+
+MY_P="Werkzeug-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/"
+SRC_URI="http://pypi.python.org/packages/source/W/Werkzeug/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=">=dev-python/setuptools-0.6_rc5
+ test? ( dev-python/py
+ dev-python/lxml
+ dev-python/simplejson )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+
+ # Rearraning the docs
+ rm -rf "${D}/usr/docs"
+ dodoc docs/src/*
+ dohtml docs/html/*
+}
+
+src_test() {
+ distutils_python_version
+ # path gets set correctly in conftest.py
+ cd tests
+ py.test || die "tests failed"
+}