summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-16 08:51:28 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-16 08:51:28 +0000
commit9d1f8a2c3bea726deb722c39bf4d6dca5ea30915 (patch)
tree9be236133389df7a8f4e1115ec9404377383e842 /dev-python/webtest
parentFix unpack stage. Closes bug #383185. (diff)
downloadgentoo-2-9d1f8a2c3bea726deb722c39bf4d6dca5ea30915.tar.gz
gentoo-2-9d1f8a2c3bea726deb722c39bf4d6dca5ea30915.tar.bz2
gentoo-2-9d1f8a2c3bea726deb722c39bf4d6dca5ea30915.zip
Version bump webtest to 1.3.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog8
-rw-r--r--dev-python/webtest/files/webtest-1.3-doctest-ellipsis.patch38
-rw-r--r--dev-python/webtest/webtest-1.3.ebuild60
3 files changed, 105 insertions, 1 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index dadabc4fa16d..4d550dfdfe0f 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.26 2011/04/29 20:10:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.27 2011/09/16 08:51:28 djc Exp $
+
+*webtest-1.3 (16 Sep 2011)
+
+ 16 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +webtest-1.3.ebuild,
+ +files/webtest-1.3-doctest-ellipsis.patch:
+ Version bump to 1.3 (fixes bug 382923, thanks to jbergstroem).
29 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> webtest-1.2.3.ebuild:
ppc64 stable wrt #365335
diff --git a/dev-python/webtest/files/webtest-1.3-doctest-ellipsis.patch b/dev-python/webtest/files/webtest-1.3-doctest-ellipsis.patch
new file mode 100644
index 000000000000..38b01ae215b0
--- /dev/null
+++ b/dev-python/webtest/files/webtest-1.3-doctest-ellipsis.patch
@@ -0,0 +1,38 @@
+diff --git a/docs/index.txt b/docs/index.txt
+index f472102..1edf711 100644
+--- a/docs/index.txt
++++ b/docs/index.txt
+@@ -271,7 +271,7 @@ Then you can submit:
+ >>> res = form.submit()
+ >>> # Or submit a button:
+ >>> res = form.submit('submit')
+- >>> print(res)
++ >>> print(res) # doctest:+ELLIPSIS
+ Response: 200 OK
+ Content-Type: text/plain
+ ...
+@@ -331,7 +331,7 @@ Examples:
+ <class 'BeautifulSoup.BeautifulSoup'>
+ >>> res.html.body.div.string
+ u'hey!'
+- >>> res.lxml
++ >>> res.lxml # doctest:+ELLIPSIS
+ <Element html at ...>
+ >>> res.lxml.xpath('//body/div')[0].text
+ 'hey!'
+@@ -343,13 +343,13 @@ Examples:
+ >>> res = TestResponse(content_type='application/xml',
+ ... body='<xml><message>hey!</message></xml>')
+ >>> res.request = TestRequest.blank('/')
+- >>> res.xml
++ >>> res.xml # doctest:+ELLIPSIS
+ <Element ...>
+ >>> res.xml[0].tag
+ 'message'
+ >>> res.xml[0].text
+ 'hey!'
+- >>> res.lxml
++ >>> res.lxml # doctest:+ELLIPSIS
+ <Element xml at ...>
+ >>> res.lxml[0].tag
+ 'message' \ No newline at end of file
diff --git a/dev-python/webtest/webtest-1.3.ebuild b/dev-python/webtest/webtest-1.3.ebuild
new file mode 100644
index 000000000000..912550658e74
--- /dev/null
+++ b/dev-python/webtest/webtest-1.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.3.ebuild,v 1.1 2011/09/16 08:51:28 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/webob-0.9.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pyquery )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-doctest-ellipsis.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ sphinx-build docs html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
+ delete_lint3() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+ rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
+ }
+ python_execute_function -q delete_lint3
+
+ if use doc; then
+ dohtml -r html/* || die "Error installing docs"
+ fi
+}