summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-24 18:10:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-24 18:10:43 +0000
commit27658ff895cde9f8df37bba0b6b3fc0660f55cde (patch)
treecfa8ba63276426177cb119bd3a2a0838688d9dfc /dev-python/webpy
parentNever set LD_LIBRARY_PATH, use LDPATH (diff)
downloadgentoo-2-27658ff895cde9f8df37bba0b6b3fc0660f55cde.tar.gz
gentoo-2-27658ff895cde9f8df37bba0b6b3fc0660f55cde.tar.bz2
gentoo-2-27658ff895cde9f8df37bba0b6b3fc0660f55cde.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webpy')
-rw-r--r--dev-python/webpy/ChangeLog6
-rw-r--r--dev-python/webpy/webpy-0.34.ebuild34
2 files changed, 26 insertions, 14 deletions
diff --git a/dev-python/webpy/ChangeLog b/dev-python/webpy/ChangeLog
index 7bf7185706d2..15104a8a6811 100644
--- a/dev-python/webpy/ChangeLog
+++ b/dev-python/webpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/webpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.15 2010/06/01 08:57:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.16 2010/06/24 18:10:43 arfrever Exp $
+
+ 24 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ webpy-0.34.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
01 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> webpy-0.32.ebuild:
x86 stable wrt bug #321431
diff --git a/dev-python/webpy/webpy-0.34.ebuild b/dev-python/webpy/webpy-0.34.ebuild
index f8f45fffbe8b..9aa39cdecfbc 100644
--- a/dev-python/webpy/webpy-0.34.ebuild
+++ b/dev-python/webpy/webpy-0.34.ebuild
@@ -1,13 +1,18 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.34.ebuild,v 1.1 2010/05/25 10:28:24 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.34.ebuild,v 1.2 2010/06/24 18:10:43 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
MY_PN="web.py"
-DESCRIPTION="A small and simple web framework for python"
-HOMEPAGE="http://www.webpy.org"
+DESCRIPTION="A small and simple web framework for Python"
+HOMEPAGE="http://www.webpy.org http://pypi.python.org/pypi/web.py"
SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
LICENSE="public-domain"
@@ -15,19 +20,22 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-DEPEND=">=dev-lang/python-2.3"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
S="${WORKDIR}/web.py-${PV}"
+
PYTHON_MODNAME="web"
src_test() {
- TESTS="db template net http utils"
-
- cd "${S}"
-
- for TEST in ${TESTS}
- do
- ${python} web/${TEST}.py || die "Doctest in web/${TEST}.py failed!"
- done
+ testing() {
+ local return_status="0" test tests="db http net template utils"
+ for test in ${tests}; do
+ echo "Running doctests in ${test}.py..."
+ "$(PYTHON)" web/${test}.py || return_status="$?"
+ done
+
+ return "${return_status}"
+ }
+ python_execute_function testing
}