summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:41:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:41:15 +0000
commitf13bdbd2f382d9fd6581cb475f1e7819441ec6ad (patch)
tree0a4c1a6593222e2a09b427ace43310e3a0866997 /dev-python/vobject
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-f13bdbd2f382d9fd6581cb475f1e7819441ec6ad.tar.gz
gentoo-2-f13bdbd2f382d9fd6581cb475f1e7819441ec6ad.tar.bz2
gentoo-2-f13bdbd2f382d9fd6581cb475f1e7819441ec6ad.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/vobject')
-rw-r--r--dev-python/vobject/ChangeLog8
-rw-r--r--dev-python/vobject/vobject-0.8.1c.ebuild17
2 files changed, 18 insertions, 7 deletions
diff --git a/dev-python/vobject/ChangeLog b/dev-python/vobject/ChangeLog
index 26fbe5fd1495..b83e37224514 100644
--- a/dev-python/vobject/ChangeLog
+++ b/dev-python/vobject/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/vobject
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vobject/ChangeLog,v 1.8 2009/09/04 15:16:49 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vobject/ChangeLog,v 1.9 2010/06/30 00:41:15 arfrever Exp $
+
+ 30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ vobject-0.8.1c.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -vobject-0.7.1.ebuild:
Remove old
diff --git a/dev-python/vobject/vobject-0.8.1c.ebuild b/dev-python/vobject/vobject-0.8.1c.ebuild
index 16d35ebc4ae2..6216cbca1349 100644
--- a/dev-python/vobject/vobject-0.8.1c.ebuild
+++ b/dev-python/vobject/vobject-0.8.1c.ebuild
@@ -1,14 +1,18 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vobject/vobject-0.8.1c.ebuild,v 1.1 2009/06/01 14:28:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vobject/vobject-0.8.1c.ebuild,v 1.2 2010/06/30 00:41:15 arfrever Exp $
-NEED_PYTHON="2.4"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="A full featured Python package for parsing and generating vCard and vCalendar files"
-HOMEPAGE="http://vobject.skyhouseconsulting.com/"
+HOMEPAGE="http://vobject.skyhouseconsulting.com/ http://pypi.python.org/pypi/vobject"
SRC_URI="http://vobject.skyhouseconsulting.com/${P}.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -21,5 +25,8 @@ DEPEND="${RDEPEND}
DOCS="ACKNOWLEDGEMENTS.txt"
src_test() {
- PYTHONPATH="${S}/src" "${python}" test_vobject.py || die "tests failed"
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test_vobject.py
+ }
+ python_execute_function testing
}