summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-02 23:27:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-02 23:27:58 +0000
commitd04a32ee1f4bf7c19a26bb41df3639aaa09c39f6 (patch)
tree68a55bf1a8e3316adbece156dae774b154652161 /dev-python/virtualenv
parentamd64/x86 stable, bug #286789 (diff)
downloadgentoo-2-d04a32ee1f4bf7c19a26bb41df3639aaa09c39f6.tar.gz
gentoo-2-d04a32ee1f4bf7c19a26bb41df3639aaa09c39f6.tar.bz2
gentoo-2-d04a32ee1f4bf7c19a26bb41df3639aaa09c39f6.zip
Version bump.
(Portage version: 14475-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/ChangeLog8
-rw-r--r--dev-python/virtualenv/virtualenv-1.3.2.ebuild24
-rw-r--r--dev-python/virtualenv/virtualenv-1.3.4.ebuild35
3 files changed, 42 insertions, 25 deletions
diff --git a/dev-python/virtualenv/ChangeLog b/dev-python/virtualenv/ChangeLog
index d11c1d2da3b5..76833d4c6ae2 100644
--- a/dev-python/virtualenv/ChangeLog
+++ b/dev-python/virtualenv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/virtualenv
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/ChangeLog,v 1.15 2009/09/27 19:02:05 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/ChangeLog,v 1.16 2009/10/02 23:27:58 arfrever Exp $
+
+*virtualenv-1.3.4 (03 Oct 2009)
+
+ 02 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -virtualenv-1.3.2.ebuild, +virtualenv-1.3.4.ebuild:
+ Version bump.
27 Sep 2009; nixnut <nixnut@gentoo.org> virtualenv-1.3.3.ebuild:
ppc stable #284994
diff --git a/dev-python/virtualenv/virtualenv-1.3.2.ebuild b/dev-python/virtualenv/virtualenv-1.3.2.ebuild
deleted file mode 100644
index 6f4531e83991..000000000000
--- a/dev-python/virtualenv/virtualenv-1.3.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/virtualenv-1.3.2.ebuild,v 1.4 2009/04/12 18:06:30 ranger Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="http://pypi.python.org/pypi/virtualenv"
-SRC_URI="http://pypi.python.org/packages/source/v/${PN}/${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="amd64 ppc ppc64 x86"
-SLOT="0"
-IUSE=""
-RDEPEND=">=dev-python/setuptools-0.6_rc8"
-DEPEND="${RDEPEND}"
-DOCS="docs/index.txt"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rm support-files/ez_setup.py
-}
diff --git a/dev-python/virtualenv/virtualenv-1.3.4.ebuild b/dev-python/virtualenv/virtualenv-1.3.4.ebuild
new file mode 100644
index 000000000000..f28581fd3844
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-1.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/virtualenv-1.3.4.ebuild,v 1.1 2009/10/02 23:27:58 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="http://pypi.python.org/pypi/virtualenv"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-python/setuptools-0.6_rc8"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="docs/index.txt"
+
+src_prepare() {
+ rm -f support-files/ez_setup.py
+}
+
+pkg_postinst() {
+ python_mod_optimize rebuild-script.py refresh-support-files.py virtualenv.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}