summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-28 18:32:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-28 18:32:17 +0000
commitf62c2e08bb0cf5e7fcd57a549a766b6e02bd0b19 (patch)
tree633406ae07b3da47b8f6b8ff34cd8fffe0437a3d /dev-python/urwid
parentVersion bump. (diff)
downloadgentoo-2-f62c2e08bb0cf5e7fcd57a549a766b6e02bd0b19.tar.gz
gentoo-2-f62c2e08bb0cf5e7fcd57a549a766b6e02bd0b19.tar.bz2
gentoo-2-f62c2e08bb0cf5e7fcd57a549a766b6e02bd0b19.zip
Version bump.
(Portage version: 15214-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/ChangeLog8
-rw-r--r--dev-python/urwid/urwid-0.9.9.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 902e51333279..d4fe58dbe15b 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.39 2010/01/07 15:55:09 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.40 2010/01/28 18:32:17 arfrever Exp $
+
+*urwid-0.9.9.1 (28 Jan 2010)
+
+ 28 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +urwid-0.9.9.1.ebuild:
+ Version bump.
07 Jan 2010; Joseph Jezak <josejx@gentoo.org> urwid-0.9.9.ebuild:
Marked ppc stable for bug #297715.
diff --git a/dev-python/urwid/urwid-0.9.9.1.ebuild b/dev-python/urwid/urwid-0.9.9.1.ebuild
new file mode 100644
index 000000000000..0b8c701d5b8c
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.9.1.ebuild,v 1.1 2010/01/28 18:32:17 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/ http://pypi.python.org/pypi/urwid"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ "$(PYTHON)" test_urwid.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bigtext.py browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}