summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-05-06 17:50:38 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-05-06 17:50:38 +0000
commit4e2b5f0360327e1f09687ee37b8dc41f37d5c3c5 (patch)
tree58870779ff8638c61b7285722ca48c95794eeaf3 /dev-python/twisted/twisted-1.2.1_alpha2.ebuild
parentAdded ~sparc, #50269 (diff)
downloadgentoo-2-4e2b5f0360327e1f09687ee37b8dc41f37d5c3c5.tar.gz
gentoo-2-4e2b5f0360327e1f09687ee37b8dc41f37d5c3c5.tar.bz2
gentoo-2-4e2b5f0360327e1f09687ee37b8dc41f37d5c3c5.zip
added 1.2.1_alpha2, marked 1.2.0 stable x86
Diffstat (limited to 'dev-python/twisted/twisted-1.2.1_alpha2.ebuild')
-rw-r--r--dev-python/twisted/twisted-1.2.1_alpha2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/twisted/twisted-1.2.1_alpha2.ebuild b/dev-python/twisted/twisted-1.2.1_alpha2.ebuild
new file mode 100644
index 000000000000..23447cb4dffc
--- /dev/null
+++ b/dev-python/twisted/twisted-1.2.1_alpha2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.1_alpha2.ebuild,v 1.1 2004/05/06 17:50:37 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/alpha}"
+DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted_NoDocs-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha"
+IUSE="gtk gtk2 doc"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/pycrypto-1.9_alpha6
+ dev-python/pyserial
+ dev-python/pyOpenSSL
+ gtk? ( gtk2? ( >=dev-python/pygtk-1.99* ) !gtk2? ( =dev-python/pygtk-0.6* ) )
+ doc? ( =dev-python/twisted-docs-${PV} )"
+
+S=${WORKDIR}/Twisted-${MY_PV}
+
+src_install() {
+ distutils_src_install
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+}