summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-19 09:01:56 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-19 09:01:56 +0000
commitaf6143eb55942cdd7558be06fb9742090151fc3e (patch)
treeec0edeb3bc630c01d1d39d20f3026f707e15c5bb /dev-python/twisted-web
parentamd64 stable, bug 474822 (diff)
downloadgentoo-2-af6143eb55942cdd7558be06fb9742090151fc3e.tar.gz
gentoo-2-af6143eb55942cdd7558be06fb9742090151fc3e.tar.bz2
gentoo-2-af6143eb55942cdd7558be06fb9742090151fc3e.zip
bump; add 1 new dep
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/ChangeLog9
-rw-r--r--dev-python/twisted-web/twisted-web-13.2.0.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index 3ae42bf1145d..6981760e028e 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-web
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.95 2013/11/24 18:37:41 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.96 2014/01/19 09:01:56 idella4 Exp $
+
+*twisted-web-13.2.0 (19 Jan 2014)
+
+ 19 Jan 2014; Ian Delaney <idella4@gentoo.org> +twisted-web-13.2.0.ebuild:
+ bump; add 1 new dep
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> twisted-web-12.3.0.ebuild:
Stable for arm, wrt bug #468150
diff --git a/dev-python/twisted-web/twisted-web-13.2.0.ebuild b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
new file mode 100644
index 000000000000..81af2eb69b84
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-13.2.0.ebuild,v 1.1 2014/01/19 09:01:56 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+SRC_URI="http://twistedmatrix.com/Releases/Web/${TWISTED_RELEASE}/${MY_PN}/${MY_PN}-${PV}.tar.bz2 -> ${P}.tar.bz2 "
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite