summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2005-11-27 22:21:34 +0000
committerMarien Zwart <marienz@gentoo.org>2005-11-27 22:21:34 +0000
commitf7fc759de5d22b0605aff2e3201b3d7e8364cd34 (patch)
treed857d52b4af94a9864e553390fd5baab3b49f0f6 /dev-python/twisted-web2/twisted-web2-0.1.ebuild
parentMarked stable on amd64 (diff)
downloadgentoo-2-f7fc759de5d22b0605aff2e3201b3d7e8364cd34.tar.gz
gentoo-2-f7fc759de5d22b0605aff2e3201b3d7e8364cd34.tar.bz2
gentoo-2-f7fc759de5d22b0605aff2e3201b3d7e8364cd34.zip
Initial import (bug #80639).
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-python/twisted-web2/twisted-web2-0.1.ebuild')
-rw-r--r--dev-python/twisted-web2/twisted-web2-0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/twisted-web2/twisted-web2-0.1.ebuild b/dev-python/twisted-web2/twisted-web2-0.1.ebuild
new file mode 100644
index 000000000000..f31e6bc3d465
--- /dev/null
+++ b/dev-python/twisted-web2/twisted-web2-0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web2/twisted-web2-0.1.ebuild,v 1.1 2005/11/27 22:21:34 marienz Exp $
+
+MY_PACKAGE=Web2
+
+inherit twisted eutils
+
+DESCRIPTION="An HTTP/1.1 Server Framework"
+
+KEYWORDS="~x86"
+
+DEPEND=">=dev-python/twisted-2"
+
+# this is not in the standard location twisted.eclass expects
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Web2/TwistedWeb2-0.1.tar.bz2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-tests-2.1-compat.patch"
+}