summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-03 08:13:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-03 08:13:57 +0000
commitb10ff1eede5969a159d0e7b4ca3045e06f8aadef (patch)
treeedffeb5a3faa7a1e39c1ed6bb4662088120b2925 /dev-python/traits/traits-4.3.0.ebuild
parentRemove old. (diff)
downloadgentoo-2-b10ff1eede5969a159d0e7b4ca3045e06f8aadef.tar.gz
gentoo-2-b10ff1eede5969a159d0e7b4ca3045e06f8aadef.tar.bz2
gentoo-2-b10ff1eede5969a159d0e7b4ca3045e06f8aadef.zip
Bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/traits/traits-4.3.0.ebuild')
-rw-r--r--dev-python/traits/traits-4.3.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/traits/traits-4.3.0.ebuild b/dev-python/traits/traits-4.3.0.ebuild
new file mode 100644
index 000000000000..5dc33d7a53b2
--- /dev/null
+++ b/dev-python/traits/traits-4.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.3.0.ebuild,v 1.1 2013/04/03 08:13:57 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
+SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/numpy )"
+
+DOCS="docs/*.txt"
+
+src_prepare() {
+ sed -i -e "s/'-O3'//g" setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+ use doc && virtualmake -C docs html
+}
+
+src_test() {
+ testing() {
+ local exit_status=0
+ pushd $(find build-${PYTHON_ABI}/ -name "${PN}") > /dev/null
+ PYTHONPATH=. nosetests -v tests || exit_status=1
+ popd > /dev/null
+ return $exit_status
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}