summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-26 15:23:11 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-26 15:23:11 +0000
commita81afc88ff004a1a1923d3bc70ac2c043c0d6379 (patch)
treec6499dd49962c9fc1ac104c69e998a40a3f8a5eb /dev-python/testresources
parentre-add pypy support (diff)
downloadgentoo-2-a81afc88ff004a1a1923d3bc70ac2c043c0d6379.tar.gz
gentoo-2-a81afc88ff004a1a1923d3bc70ac2c043c0d6379.tar.bz2
gentoo-2-a81afc88ff004a1a1923d3bc70ac2c043c0d6379.zip
add pypy support
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/ChangeLog6
-rw-r--r--dev-python/testresources/testresources-0.2.7-r1.ebuild27
-rw-r--r--dev-python/testresources/testresources-0.2.7-r2.ebuild4
-rw-r--r--dev-python/testresources/testresources-0.2.7.ebuild27
4 files changed, 7 insertions, 57 deletions
diff --git a/dev-python/testresources/ChangeLog b/dev-python/testresources/ChangeLog
index 4869c3d1b447..f0e06371e7ca 100644
--- a/dev-python/testresources/ChangeLog
+++ b/dev-python/testresources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/testresources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/ChangeLog,v 1.23 2015/06/09 17:14:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/ChangeLog,v 1.24 2015/07/26 15:23:11 idella4 Exp $
+
+ 26 Jul 2015; Ian Delaney <idella4@gentoo.org> -testresources-0.2.7-r1.ebuild,
+ -testresources-0.2.7.ebuild, testresources-0.2.7-r2.ebuild:
+ add pypy support
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/dev-python/testresources/testresources-0.2.7-r1.ebuild b/dev-python/testresources/testresources-0.2.7-r1.ebuild
deleted file mode 100644
index 7a4ad9f6cc42..000000000000
--- a/dev-python/testresources/testresources-0.2.7-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/testresources-0.2.7-r1.ebuild,v 1.9 2015/04/08 08:05:01 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Testresources, a pyunit extension for managing expensive test resources"
-HOMEPAGE="https://launchpad.net/testresources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/testresources/testresources-0.2.7-r2.ebuild b/dev-python/testresources/testresources-0.2.7-r2.ebuild
index 188ab4cdaf1b..c16a0a37c28b 100644
--- a/dev-python/testresources/testresources-0.2.7-r2.ebuild
+++ b/dev-python/testresources/testresources-0.2.7-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/testresources-0.2.7-r2.ebuild,v 1.13 2015/04/14 12:51:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/testresources-0.2.7-r2.ebuild,v 1.14 2015/07/26 15:23:11 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
diff --git a/dev-python/testresources/testresources-0.2.7.ebuild b/dev-python/testresources/testresources-0.2.7.ebuild
deleted file mode 100644
index b6ed08cbba0e..000000000000
--- a/dev-python/testresources/testresources-0.2.7.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/testresources-0.2.7.ebuild,v 1.6 2015/04/08 08:05:01 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Testresources, a pyunit extension for managing expensive test resources"
-HOMEPAGE="https://launchpad.net/testresources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}