summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 22:05:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 22:05:29 +0000
commit5cfbe779182a8a5c41e3f92969d54d39384d461b (patch)
tree81a1a651f5f914cdc91bbad56436272780e876db /dev-python/tagpy
parentApply changes for prefix to qt4-build.eclass (diff)
downloadgentoo-2-5cfbe779182a8a5c41e3f92969d54d39384d461b.tar.gz
gentoo-2-5cfbe779182a8a5c41e3f92969d54d39384d461b.tar.bz2
gentoo-2-5cfbe779182a8a5c41e3f92969d54d39384d461b.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 15152-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/ChangeLog8
-rw-r--r--dev-python/tagpy/tagpy-0.94.7.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/tagpy/ChangeLog b/dev-python/tagpy/ChangeLog
index 8f98364ae77e..34948872f361 100644
--- a/dev-python/tagpy/ChangeLog
+++ b/dev-python/tagpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/tagpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.27 2009/10/08 18:32:11 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.28 2009/12/24 22:05:29 arfrever Exp $
+
+*tagpy-0.94.7 (24 Dec 2009)
+
+ 24 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +tagpy-0.94.7.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
07 Oct 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
tagpy-0.94.5-r1.ebuild:
diff --git a/dev-python/tagpy/tagpy-0.94.7.ebuild b/dev-python/tagpy/tagpy-0.94.7.ebuild
new file mode 100644
index 000000000000..5bac3aff3cad
--- /dev/null
+++ b/dev-python/tagpy/tagpy-0.94.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-0.94.7.ebuild,v 1.1 2009/12/24 22:05:29 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="http://mathema.tician.de//software/tagpy http://pypi.python.org/pypi/tagpy"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/taglib-1.4
+ || ( <dev-libs/boost-1.35.0-r5 >=dev-libs/boost-1.35.0-r5[python] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_configure() {
+ ./configure.py \
+ --taglib-inc-dir="/usr/include/taglib" \
+ --boost-python-libname="boost_python-mt" || die "Configuration failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+}