summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-07-24 05:58:16 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-07-24 05:58:16 +0000
commita766048e31eed9e46e9f272b94a627d72397f7e3 (patch)
treedd03ec8063846fde017faef5cf8d6f6c98848f9f /dev-python/suds
parentStable for HPPA (bug #554970). (diff)
downloadgentoo-2-a766048e31eed9e46e9f272b94a627d72397f7e3.tar.gz
gentoo-2-a766048e31eed9e46e9f272b94a627d72397f7e3.tar.bz2
gentoo-2-a766048e31eed9e46e9f272b94a627d72397f7e3.zip
converting to suds-jurko as the source as upstream is dead
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/suds')
-rw-r--r--dev-python/suds/ChangeLog7
-rw-r--r--dev-python/suds/suds-0.6.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/suds/ChangeLog b/dev-python/suds/ChangeLog
index 628efeca91c0..c2376fd991f7 100644
--- a/dev-python/suds/ChangeLog
+++ b/dev-python/suds/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/suds
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/ChangeLog,v 1.15 2015/07/21 20:38:12 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/ChangeLog,v 1.16 2015/07/24 05:58:16 prometheanfire Exp $
+
+*suds-0.6 (24 Jul 2015)
+
+ 24 Jul 2015; Matthew Thode <prometheanfire@gentoo.org> +suds-0.6.ebuild:
+ converting to suds-jurko as the source as upstream is dead
21 Jul 2015; Manuel Rüger <mrueg@gentoo.org> -suds-0.4.ebuild:
Remove old.
diff --git a/dev-python/suds/suds-0.6.ebuild b/dev-python/suds/suds-0.6.ebuild
new file mode 100644
index 000000000000..7d3748a7f018
--- /dev/null
+++ b/dev-python/suds/suds-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/suds-0.6.ebuild,v 1.1 2015/07/24 05:58:16 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client (Jurko's fork) (py3 support) (active development)"
+HOMEPAGE="http://bitbucket.org/jurko/suds"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}-jurko/${PN}-jurko-${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-jurko-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare() {
+ rm -R tests
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv suds_jurko.egg-info suds.egg-info || die
+ sed -i -e 's/Name\:\ suds-jurko/Name:\ suds/g' -e '/^Obsoletes/d' suds.egg-info/PKG-INFO || die
+}