summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-02-08 06:57:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-02-08 06:57:46 +0000
commit693266692baddbe7773fbcf0730aa8c54280c5ef (patch)
treec3722df0601b3d9f420c6e253b9b29da2cc8abc3 /dev-python/subunit
parentFix build failure when default shell is dash (bug #401329 by Anthony Parsons). (diff)
downloadgentoo-2-693266692baddbe7773fbcf0730aa8c54280c5ef.tar.gz
gentoo-2-693266692baddbe7773fbcf0730aa8c54280c5ef.tar.bz2
gentoo-2-693266692baddbe7773fbcf0730aa8c54280c5ef.zip
Bump for #401959
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog9
-rw-r--r--dev-python/subunit/subunit-0.0.7.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 13c3de644bcd..5141fdf95d21 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subunit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.12 2011/04/16 16:05:16 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.13 2012/02/08 06:57:46 patrick Exp $
+
+*subunit-0.0.7 (08 Feb 2012)
+
+ 08 Feb 2012; Patrick Lauer <patrick@gentoo.org> +subunit-0.0.7.ebuild:
+ Bump for #401959
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> subunit-0.0.6.ebuild:
ia64 stable wrt #343309
diff --git a/dev-python/subunit/subunit-0.0.7.ebuild b/dev-python/subunit/subunit-0.0.7.ebuild
new file mode 100644
index 000000000000..4c090a52da2f
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.7.ebuild,v 1.1 2012/02/08 06:57:46 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit python
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.4"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ dev-util/pkgconfig"
+RESTRICT_PYTHON_ABIS="3.*"
+
+pkg_postinst() {
+ python_mod_optimize subunit
+}
+
+pkg_postrm() {
+ python_mod_cleanup subunit
+}