summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-14 17:21:43 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-14 17:21:43 +0000
commit8ea088de53a6795cc217f5b1ce87cbf61f9434b3 (patch)
tree4a95e629c857e09346ebdbb159bb7f1e7119d673 /dev-python/stevedore
parentFix tests by David Leverton <levertond@googlemail.com> wrt bug #467720. (diff)
downloadgentoo-2-8ea088de53a6795cc217f5b1ce87cbf61f9434b3.tar.gz
gentoo-2-8ea088de53a6795cc217f5b1ce87cbf61f9434b3.tar.bz2
gentoo-2-8ea088de53a6795cc217f5b1ce87cbf61f9434b3.zip
corrections to 0.8-r1 inc. setting of <setuptools-0.7, fixes Bug #473278, bump, removed 0.8
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog8
-rw-r--r--dev-python/stevedore/stevedore-0.8-r1.ebuild12
-rw-r--r--dev-python/stevedore/stevedore-0.8.ebuild23
-rw-r--r--dev-python/stevedore/stevedore-0.9.1.ebuild45
4 files changed, 59 insertions, 29 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index be4abd2f2f7f..6b3c7d87b21b 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.3 2013/04/19 07:39:32 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.4 2013/06/14 17:21:43 idella4 Exp $
+
+*stevedore-0.9.1 (14 Jun 2013)
+
+ 14 Jun 2013; Ian Delaney <idella4@gentoo.org> +stevedore-0.9.1.ebuild,
+ stevedore-0.8-r1.ebuild:
+ corrections to 0.8-r1 inc. setting of <setuptools-0.7, fixes Bug #473278, bump
*stevedore-0.8-r1 (19 Apr 2013)
diff --git a/dev-python/stevedore/stevedore-0.8-r1.ebuild b/dev-python/stevedore/stevedore-0.8-r1.ebuild
index c6eb2530101f..c6215dcdd9e9 100644
--- a/dev-python/stevedore/stevedore-0.8-r1.ebuild
+++ b/dev-python/stevedore/stevedore-0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.8-r1.ebuild,v 1.1 2013/04/19 07:39:32 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.8-r1.ebuild,v 1.2 2013/06/14 17:21:43 idella4 Exp $
EAPI=5
@@ -18,18 +18,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+DEPEND="<dev-python/setuptools-0.7[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- nosetests || die
+ nosetests || die "Tests failed under ${EPYTHON}"
}
python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
distutils-r1_python_install_all
- use doc && dohtml -r docs/build/html/
}
diff --git a/dev-python/stevedore/stevedore-0.8.ebuild b/dev-python/stevedore/stevedore-0.8.ebuild
deleted file mode 100644
index 5edc7683af07..000000000000
--- a/dev-python/stevedore/stevedore-0.8.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.8.ebuild,v 1.1 2013/01/26 05:41:06 prometheanfire Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6 3:3.1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 *-jython 2.7-pypy-*"
-
-inherit distutils python
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
diff --git a/dev-python/stevedore/stevedore-0.9.1.ebuild b/dev-python/stevedore/stevedore-0.9.1.ebuild
new file mode 100644
index 000000000000..dc155a5c7938
--- /dev/null
+++ b/dev-python/stevedore/stevedore-0.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.9.1.ebuild,v 1.1 2013/06/14 17:21:43 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/dreamhost/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="<dev-python/setuptools-0.7[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
+RDEPEND=""
+
+python_compile_all() {
+ if use doc; then
+ mkdir docs/source/_build || die
+ sphinx-build -b html -c docs/source docs/source/ docs/source/_build
+ fi
+}
+
+python_test() {
+ nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
+ || die "Tests failed under ${EPYTHON}"
+ flake8 stevedore setup.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/. )
+ distutils-r1_python_install_all
+}