summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-08 05:06:31 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-08 05:06:31 +0000
commite62531d9521f43fa4940713936a5e67df58a2dfa (patch)
treeb41cd2b5eb9d00772e872db556546e28cc504845 /dev-python/sip/sip-4.1.1.ebuild
parentNew tarball (diff)
downloadgentoo-2-e62531d9521f43fa4940713936a5e67df58a2dfa.tar.gz
gentoo-2-e62531d9521f43fa4940713936a5e67df58a2dfa.tar.bz2
gentoo-2-e62531d9521f43fa4940713936a5e67df58a2dfa.zip
Multilib fix for python.
(Portage version: 2.0.51.16)
Diffstat (limited to 'dev-python/sip/sip-4.1.1.ebuild')
-rw-r--r--dev-python/sip/sip-4.1.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/sip/sip-4.1.1.ebuild b/dev-python/sip/sip-4.1.1.ebuild
index 7b6c20bf6dc0..7fac27614c7d 100644
--- a/dev-python/sip/sip-4.1.1.ebuild
+++ b/dev-python/sip/sip-4.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.1.1.ebuild,v 1.6 2004/12/19 20:42:42 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.1.1.ebuild,v 1.7 2005/02/08 05:06:31 eradicator Exp $
inherit distutils
@@ -23,7 +23,7 @@ DEPEND="virtual/libc
src_compile(){
distutils_python_version
- local myconf="-l qt-mt -b /usr/bin -d /usr/lib/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
+ local myconf="-l qt-mt -b /usr/bin -d /usr/$(get_libdir)/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
use debug && myconf="${myconf} -u"
python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
@@ -31,7 +31,7 @@ src_compile(){
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
+ make DESTDIR="${D}" install || die "install failed"
dodoc ChangeLog LICENSE NEWS README THANKS TODO
if use doc ; then dohtml doc/* ; fi
}