summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-12 01:11:14 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-12 01:11:14 +0000
commitaf7308d140059296463a3053dd5d1da952ad7e66 (patch)
tree6410e05b836b73ad2e339bb5afe0208fa37fc1da /dev-python/singledispatch
parentKeyworded on ~ppc ~ppc64, bug #458196 (diff)
downloadgentoo-2-af7308d140059296463a3053dd5d1da952ad7e66.tar.gz
gentoo-2-af7308d140059296463a3053dd5d1da952ad7e66.tar.bz2
gentoo-2-af7308d140059296463a3053dd5d1da952ad7e66.zip
new package which backports functools.singledispatch to <py3.4, required now by testsuite of >=rpy.2.5.0
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/singledispatch')
-rw-r--r--dev-python/singledispatch/ChangeLog10
-rw-r--r--dev-python/singledispatch/Manifest3
-rw-r--r--dev-python/singledispatch/metadata.xml5
-rw-r--r--dev-python/singledispatch/singledispatch-3.4.0.3.ebuild20
4 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/singledispatch/ChangeLog b/dev-python/singledispatch/ChangeLog
new file mode 100644
index 000000000000..911f1f3e6197
--- /dev/null
+++ b/dev-python/singledispatch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/singledispatch
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/singledispatch/ChangeLog,v 1.1 2014/11/12 01:11:14 idella4 Exp $
+
+*singledispatch-3.4.0.3 (12 Nov 2014)
+
+ 12 Nov 2014; Ian Delaney <idella4@gentoo.org> +metadata.xml,
+ +singledispatch-3.4.0.3.ebuild:
+ new package which backports functools.singledispatch to <py3.4, required now
+ by testsuite of >=rpy.2.5.0
diff --git a/dev-python/singledispatch/Manifest b/dev-python/singledispatch/Manifest
new file mode 100644
index 000000000000..c7b61922e725
--- /dev/null
+++ b/dev-python/singledispatch/Manifest
@@ -0,0 +1,3 @@
+DIST singledispatch-3.4.0.3.tar.gz 9529 SHA256 5b06af87df13818d14f08a028e42f566640aef80805c3b50c5056b086e3c2b9c SHA512 ba065d36092ddee6527be3d7cb777c51c0949855bf6dd0ffb7c25acaedaa35d36fe6dc096587acddcd1e9e54c6ac5f92c196b11f9ee1270cc0c1cf2f410446cf WHIRLPOOL 183ff853db1743b9a55023a62afc806d60dc095f8a1a32392ad3d48c31f0c9b2b2001dc9bd264c90dbfc7acb92670342a2ff770886aa81afe9b5badde4dbe22a
+EBUILD singledispatch-3.4.0.3.ebuild 567 SHA256 da74123423497c42c66df304cb3f7fe6ea559bbf2642e77f10b0098c6d1bdbcb SHA512 690c3cc4817875b6a1f8c8eba6becd7462887c99ae63c7e9a8582a564ba0284abacfb85a76501d71e52c8a9588a3faa5da334e3ce75f4d1dc6bef07c56ecefe5 WHIRLPOOL f1f4159e0dff8fe2e979a884f0b30bcbeae3b33b55ae2972ddab039a679d0a8550831361558b05b1aced5287ecceff3ba34e78cfd8d2090742c8208bf59bfb31
+MISC metadata.xml 160 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a SHA512 7c02a1de1ddcb6b7c6378cceff0458da3a15d5381417f7cdf01874e7c372664b8899863f41b3a2fd8d6ad67ceb732dac6da0cc17575bf8e3e6d89480417c6628 WHIRLPOOL ed2795e4466eda8c804d5067c87386e269a59fe959393057ca5ddc36851e00f5210c4da1adf4bbdfdbb7d1d3d5c60aced25727ca12fdc8305d9e263a3aca9b13
diff --git a/dev-python/singledispatch/metadata.xml b/dev-python/singledispatch/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/singledispatch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
new file mode 100644
index 000000000000..cc2c0f7a9b7e
--- /dev/null
+++ b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild,v 1.1 2014/11/12 01:11:14 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to bring functools.singledispatch from Python 3.4 to Python 2.6-3.3"
+HOMEPAGE="http://docs.python.org/3/library/functools.html#functools.singledispatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"