summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2011-03-20 19:58:45 +0000
committerTomás Touceda <chiiph@gentoo.org>2011-03-20 19:58:45 +0000
commitbda947c4c90cfe70935f4af555b301c114b0e02f (patch)
treee2c04c2b01856948ac82d3474e6c0fd788d9aa41 /dev-python/shiboken
parentx11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly (diff)
downloadgentoo-2-bda947c4c90cfe70935f4af555b301c114b0e02f.tar.gz
gentoo-2-bda947c4c90cfe70935f4af555b301c114b0e02f.tar.bz2
gentoo-2-bda947c4c90cfe70935f4af555b301c114b0e02f.zip
Version bump
(Portage version: 2.2.0_alpha26/cvs/Linux i686)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog10
-rw-r--r--dev-python/shiboken/files/shiboken-1.0.0-fix-pkgconfig.patch20
-rw-r--r--dev-python/shiboken/shiboken-1.0.0.ebuild40
3 files changed, 68 insertions, 2 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 1c07cf3e3596..107bc896facd 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/shiboken
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.7 2010/12/29 06:42:20 ayoy Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.8 2011/03/20 19:58:45 chiiph Exp $
+
+*shiboken-1.0.0 (20 Mar 2011)
+
+ 20 Mar 2011; Tomas Touceda <chiiph@gentoo.org> +shiboken-1.0.0.ebuild,
+ +files/shiboken-1.0.0-fix-pkgconfig.patch:
+ Version bump
*shiboken-0.5.1-r1 (29 Dec 2010)
diff --git a/dev-python/shiboken/files/shiboken-1.0.0-fix-pkgconfig.patch b/dev-python/shiboken/files/shiboken-1.0.0-fix-pkgconfig.patch
new file mode 100644
index 000000000000..208ec2579827
--- /dev/null
+++ b/dev-python/shiboken/files/shiboken-1.0.0-fix-pkgconfig.patch
@@ -0,0 +1,20 @@
+diff -Naur shiboken-1.0.0~beta5.orig/data/shiboken.pc.in shiboken-1.0.0~beta5/data/shiboken.pc.in
+--- shiboken-1.0.0~beta5.orig/data/shiboken.pc.in 2011-02-02 11:39:04.000000000 -0300
++++ shiboken-1.0.0~beta5/data/shiboken.pc.in 2011-02-17 11:06:16.843572611 -0300
+@@ -1,7 +1,8 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=@CMAKE_INSTALL_PREFIX@
+ libdir=@LIB_INSTALL_DIR@
+-includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken
++shiboken_SUFFIX=@shiboken_SUFFIX@
++includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken${shiboken_SUFFIX}
+ generator_location=@CMAKE_INSTALL_PREFIX@/bin/@SHIBOKEN_GENERATOR@
+ python_interpreter=@PYTHON_EXECUTABLE@
+ python_include_dir=@SBK_PYTHON_INCLUDE_DIR@
+@@ -11,5 +12,5 @@
+ Description: Support library for Python bindings created with Shiboken generator.
+ Version: @shiboken_VERSION@
+ Libs: @SBK_PYTHON_LIBRARIES@ -L${libdir} -lshiboken@shiboken_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@
+-Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/@shiboken_SUFFIX@@SBK_PKG_CONFIG_PY_DEBUG_DEFINITION@
++Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/
+
diff --git a/dev-python/shiboken/shiboken-1.0.0.ebuild b/dev-python/shiboken/shiboken-1.0.0.ebuild
new file mode 100644
index 000000000000..7d83eec019c0
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.0.0.ebuild,v 1.1 2011/03/20 19:58:45 chiiph Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2:2.5"
+
+inherit cmake-utils python versionator
+
+MY_PV=$(replace_version_separator '_' '~')
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-python/apiextractor-0.8.1
+ >=dev-python/generatorrunner-0.6.1
+ >=x11-libs/qt-core-4.5.0"
+RDEPEND="${DEPEND}
+ !dev-python/boostpythongenerator"
+
+PATCHES=( "${FILESDIR}/${P}-fix-pkgconfig.patch" )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog || die "dodoc failed"
+}