summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-09-20 23:15:39 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-09-20 23:15:39 +0000
commit77ff0546e8ac17466fd90beb365164a9127c86be (patch)
treeb053d7e8588c669e0c22585de266d563ec0a6e5a /dev-python/shiboken
parentVersion bump. Removed old (diff)
downloadgentoo-2-77ff0546e8ac17466fd90beb365164a9127c86be.tar.gz
gentoo-2-77ff0546e8ac17466fd90beb365164a9127c86be.tar.bz2
gentoo-2-77ff0546e8ac17466fd90beb365164a9127c86be.zip
Fix tests with python3, thanks to kensington for the patch (bug 502238). Drop deprecated python targets. Simplify deps.
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog7
-rw-r--r--dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch49
-rw-r--r--dev-python/shiboken/shiboken-1.2.2.ebuild27
3 files changed, 70 insertions, 13 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 83a4b029c573..154559ce969d 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.53 2014/08/27 12:14:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.54 2014/09/20 23:15:39 pesa Exp $
+
+ 20 Sep 2014; Davide Pesavento <pesa@gentoo.org>
+ +files/1.2.2-Fix-tests-with-Python-3.patch, shiboken-1.2.2.ebuild:
+ Fix tests with python3, thanks to kensington for the patch (bug 502238). Drop
+ deprecated python targets. Simplify deps.
27 Aug 2014; Anthony G. Basile <blueness@gentoo.org> shiboken-1.1.2-r1.ebuild,
shiboken-1.2.1-r1.ebuild, shiboken-1.2.2.ebuild:
diff --git a/dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch b/dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch
new file mode 100644
index 000000000000..48e401d1be1d
--- /dev/null
+++ b/dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch
@@ -0,0 +1,49 @@
+From 7f793442316599ca25014a3d39c5de56c384990f Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Fri, 23 May 2014 18:10:20 +1000
+Subject: [PATCH] Fix tests with Python 3.
+
+Change-Id: Ibbf54406ba33dd1f645a46d63c04269868288768
+---
+ tests/minimalbinding/typedef_test.py | 2 +-
+ tests/samplebinding/overflow_test.py | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/minimalbinding/typedef_test.py b/tests/minimalbinding/typedef_test.py
+index 089b279..b5535fb 100644
+--- a/tests/minimalbinding/typedef_test.py
++++ b/tests/minimalbinding/typedef_test.py
+@@ -30,7 +30,7 @@ from py3kcompat import IS_PY3K
+
+ try:
+ import numpy as np
+-except ImportError, e:
++except ImportError:
+ np = None
+
+
+diff --git a/tests/samplebinding/overflow_test.py b/tests/samplebinding/overflow_test.py
+index 5020872..c294c13 100644
+--- a/tests/samplebinding/overflow_test.py
++++ b/tests/samplebinding/overflow_test.py
+@@ -45,7 +45,7 @@ class OverflowTest(unittest.TestCase):
+ '''C++ function receives an long long argument and raise OverflowError if the value is negative.'''
+ val = 100
+ self.assertEqual(doubleLongLong(val), 2 * val)
+- val = long(100)
++ val = int(100)
+ self.assertEqual(doubleLongLong(val), 2 * val)
+ val = (2 << 64) + 1
+ self.assertRaises(OverflowError, doubleLongLong, val)
+@@ -54,7 +54,7 @@ class OverflowTest(unittest.TestCase):
+ '''C++ function receives an unsigned long long argument and raise OverflowError if the value is negative.'''
+ val = 100
+ self.assertEqual(doubleUnsignedLongLong(val), 2 * val)
+- val = long(100)
++ val = int(100)
+ self.assertEqual(doubleUnsignedLongLong(val), 2 * val)
+ val *= -1
+ self.assertRaises(OverflowError, doubleUnsignedLongLong, val)
+--
+2.1.0
+
diff --git a/dev-python/shiboken/shiboken-1.2.2.ebuild b/dev-python/shiboken/shiboken-1.2.2.ebuild
index 0a39694c8d11..d45e2918901d 100644
--- a/dev-python/shiboken/shiboken-1.2.2.ebuild
+++ b/dev-python/shiboken/shiboken-1.2.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.2.2.ebuild,v 1.3 2014/08/27 12:14:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.2.2.ebuild,v 1.4 2014/09/20 23:15:39 pesa Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit multilib cmake-utils python-r1
+inherit cmake-utils multilib python-r1
DESCRIPTION="A tool for creating Python bindings for C++ libraries"
HOMEPAGE="http://qt-project.org/wiki/PySide"
@@ -18,20 +18,21 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="
- >=dev-libs/libxml2-2.6.32
- >=dev-libs/libxslt-1.1.19
- >=dev-qt/qtcore-4.7.0:4
- >=dev-qt/qtxmlpatterns-4.7.0:4
- !dev-python/apiextractor
- !dev-python/generatorrunner
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-qt/qtcore:4
+ dev-qt/qtxmlpatterns:4
"
DEPEND="${RDEPEND}
test? (
- >=dev-qt/qtgui-4.7.0:4
- >=dev-qt/qttest-4.7.0:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
)"
DOCS=( AUTHORS ChangeLog )
+PATCHES=(
+ "${FILESDIR}/${PV}-Fix-tests-with-Python-3.patch"
+)
src_prepare() {
# Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
@@ -43,6 +44,8 @@ src_prepare() {
cp "${FILESDIR}"/rpath.cmake . || die
sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
fi
+
+ cmake-utils_src_prepare
}
src_configure() {
@@ -69,7 +72,7 @@ src_configure() {
}
src_compile() {
- python_foreach_impl cmake-utils_src_make
+ python_foreach_impl cmake-utils_src_compile
}
src_test() {