summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-27 05:16:34 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-27 05:16:34 +0000
commitcb74b54d5d82305ac0483139db04a56b824e1b2e (patch)
tree01fd90eae3e706ac0d6d4aa9e068d92bab022c00 /dev-python/setuptools/setuptools-1.1.ebuild
parent4.8.1 p1.1: Fixes bug #475350 (add --disable-werror to libatomic and libitm) (diff)
downloadgentoo-2-cb74b54d5d82305ac0483139db04a56b824e1b2e.tar.gz
gentoo-2-cb74b54d5d82305ac0483139db04a56b824e1b2e.tar.bz2
gentoo-2-cb74b54d5d82305ac0483139db04a56b824e1b2e.zip
Version bump.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/setuptools/setuptools-1.1.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/setuptools/setuptools-1.1.ebuild b/dev-python/setuptools/setuptools-1.1.ebuild
new file mode 100644
index 000000000000..80c396f79d58
--- /dev/null
+++ b/dev-python/setuptools/setuptools-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-1.1.ebuild,v 1.1 2013/08/27 05:16:34 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm -f setuptools/tests/test_packageindex.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Fails test_setup_requires under python2.5; probably a distutils bug
+ esetup.py test
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}