summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-17 11:44:56 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-17 11:44:56 +0000
commitbaf4e2b04bf149c89193bccf4d9cc8bce5b278b6 (patch)
treede0e0b676f98bc30fe9df2e1fd36f3de19fc0281 /dev-python/scimath
parentadd missing (pypy support and test phase) and matching patch (diff)
downloadgentoo-2-baf4e2b04bf149c89193bccf4d9cc8bce5b278b6.tar.gz
gentoo-2-baf4e2b04bf149c89193bccf4d9cc8bce5b278b6.tar.bz2
gentoo-2-baf4e2b04bf149c89193bccf4d9cc8bce5b278b6.zip
remove old, minor cleanup to -4.1.2-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/scimath')
-rw-r--r--dev-python/scimath/ChangeLog6
-rw-r--r--dev-python/scimath/scimath-4.0.0.ebuild59
-rw-r--r--dev-python/scimath/scimath-4.0.1.ebuild48
-rw-r--r--dev-python/scimath/scimath-4.1.0.ebuild48
-rw-r--r--dev-python/scimath/scimath-4.1.2-r1.ebuild7
5 files changed, 8 insertions, 160 deletions
diff --git a/dev-python/scimath/ChangeLog b/dev-python/scimath/ChangeLog
index 17bbcc481831..816598fca324 100644
--- a/dev-python/scimath/ChangeLog
+++ b/dev-python/scimath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/scimath
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.15 2013/04/16 06:39:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.16 2013/06/17 11:44:56 idella4 Exp $
+
+ 17 Jun 2013; Ian Delaney <idella4@gentoo.org> -scimath-4.0.0.ebuild,
+ -scimath-4.0.1.ebuild, -scimath-4.1.0.ebuild, scimath-4.1.2-r1.ebuild:
+ remove old, minor cleanup to -4.1.2-r1
*scimath-4.1.2-r1 (16 Apr 2013)
diff --git a/dev-python/scimath/scimath-4.0.0.ebuild b/dev-python/scimath/scimath-4.0.0.ebuild
deleted file mode 100644
index c06c675006ad..000000000000
--- a/dev-python/scimath/scimath-4.0.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.0.0.ebuild,v 1.2 2012/02/24 09:40:50 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
-HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/traits-4.0
- >=dev-python/traitsui-4.0
- sci-libs/scipy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/scimath/scimath-4.0.1.ebuild b/dev-python/scimath/scimath-4.0.1.ebuild
deleted file mode 100644
index c939f329d5a9..000000000000
--- a/dev-python/scimath/scimath-4.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.0.1.ebuild,v 1.2 2012/02/24 09:40:50 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
-HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/traits-4.1
- >=dev-python/traitsui-4.1
- sci-libs/scipy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C docs html
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-}
diff --git a/dev-python/scimath/scimath-4.1.0.ebuild b/dev-python/scimath/scimath-4.1.0.ebuild
deleted file mode 100644
index dd921ea37260..000000000000
--- a/dev-python/scimath/scimath-4.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.1.0.ebuild,v 1.2 2012/12/06 19:16:15 bicatali Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
-HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/traits-4.1
- >=dev-python/traitsui-4.1
- sci-libs/scipy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C docs html
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-}
diff --git a/dev-python/scimath/scimath-4.1.2-r1.ebuild b/dev-python/scimath/scimath-4.1.2-r1.ebuild
index 270d30911f4c..f892049caa1e 100644
--- a/dev-python/scimath/scimath-4.1.2-r1.ebuild
+++ b/dev-python/scimath/scimath-4.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.1.2-r1.ebuild,v 1.1 2013/04/16 06:39:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.1.2-r1.ebuild,v 1.2 2013/06/17 11:44:56 idella4 Exp $
EAPI=5
@@ -35,13 +35,12 @@ python_compile_all() {
}
python_test() {
- # ONE test assumes PYTHONPATH in its own dir!!! ! !! !
+ # ONE test assumes PYTHONPATH in its own dir!!!
PYTHONPATH=build/lib/:build/lib/scimath/interpolate/
VIRTUALX_COMMAND="nosetests" virtualmake
}
python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
distutils-r1_python_install_all
-
- use doc && dohtml -r docs/build/html/*
}