summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-27 03:30:59 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-27 03:30:59 +0000
commit865290d5f8a3ddee7432e9cf494a0a44face06d2 (patch)
treee0c5ce417a1451fdba82044944ea4f3da5a42bb1 /dev-python/routes
parentupdate SRC_URI (diff)
downloadgentoo-2-865290d5f8a3ddee7432e9cf494a0a44face06d2.tar.gz
gentoo-2-865290d5f8a3ddee7432e9cf494a0a44face06d2.tar.bz2
gentoo-2-865290d5f8a3ddee7432e9cf494a0a44face06d2.zip
return -1.13-r1, needed still by some
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/ChangeLog7
-rw-r--r--dev-python/routes/routes-1.13-r1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/routes/ChangeLog b/dev-python/routes/ChangeLog
index 14896e43fd43..39ff1c786ef4 100644
--- a/dev-python/routes/ChangeLog
+++ b/dev-python/routes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/routes
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.26 2015/03/26 04:12:08 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.27 2015/03/27 03:30:59 idella4 Exp $
+
+*routes-1.13-r1 (27 Mar 2015)
+
+ 27 Mar 2015; Ian Delaney <idella4@gentoo.org> +routes-1.13-r1.ebuild:
+ return -1.13-r1, needed still by some
*routes-2.1 (26 Mar 2015)
diff --git a/dev-python/routes/routes-1.13-r1.ebuild b/dev-python/routes/routes-1.13-r1.ebuild
new file mode 100644
index 000000000000..7be79a8b778c
--- /dev/null
+++ b/dev-python/routes/routes-1.13-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.13-r1.ebuild,v 1.6 2015/03/27 03:30:59 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+# Note: although setup.py states that tests require webtest,
+# it isn't used anywhere.
+RDEPEND="dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}