summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-08-12 17:32:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-08-12 17:32:01 +0000
commite1d6f7d63072b7413adccee9dcd1ded2884c6bc9 (patch)
treed15eb79b1513e79618f2149fcbd225cbc24b6db4 /dev-python/rootpy
parentremove old (diff)
downloadgentoo-2-e1d6f7d63072b7413adccee9dcd1ded2884c6bc9.tar.gz
gentoo-2-e1d6f7d63072b7413adccee9dcd1ded2884c6bc9.tar.bz2
gentoo-2-e1d6f7d63072b7413adccee9dcd1ded2884c6bc9.zip
Initial import
(Portage version: 2.2.01.22124-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/rootpy')
-rw-r--r--dev-python/rootpy/ChangeLog9
-rw-r--r--dev-python/rootpy/Manifest3
-rw-r--r--dev-python/rootpy/metadata.xml13
-rw-r--r--dev-python/rootpy/rootpy-0.7.1.ebuild46
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/rootpy/ChangeLog b/dev-python/rootpy/ChangeLog
new file mode 100644
index 000000000000..da8e6e4c1b49
--- /dev/null
+++ b/dev-python/rootpy/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/rootpy
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rootpy/ChangeLog,v 1.1 2013/08/12 17:32:01 bicatali Exp $
+
+*rootpy-0.7.1 (12 Aug 2013)
+
+ 12 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +rootpy-0.7.1.ebuild:
+ Initial import
diff --git a/dev-python/rootpy/Manifest b/dev-python/rootpy/Manifest
new file mode 100644
index 000000000000..606bbf7e3eef
--- /dev/null
+++ b/dev-python/rootpy/Manifest
@@ -0,0 +1,3 @@
+DIST rootpy-0.7.1.tar.gz 305412 SHA256 d36399125ed8540b9a651e7b5c7ddeba686ef3107830d3d6d840cdae4834751c SHA512 460e5d79da08c141c762a5a92cf50694fe1fee8677a2439b5525b67e7d6a1a6af18a4e6dc91d379b394a97dc973da8f6baa534d46e506e0a7a4d0ee632de1a2a WHIRLPOOL d9663274a36c490bb4c872be83527d3dd414d9cca989cf20a2aca1ac5441532c9b29571d0ff885458fd2e820dc7905a679e1c9873305848ccd1fafa7820a84be
+EBUILD rootpy-0.7.1.ebuild 1155 SHA256 8db27d527cbfe1009ae765177e210a0b867b3984c7c087d4989d96ea9d2c53fc SHA512 8ad2ad7a923cd6bd51a0dcb623133d44620c067fde953087d5209dea98b391677b4a160e2d1fe3534718f13713c23984e1d471e913aba252a057b660e237fd37 WHIRLPOOL e70c3e5473370b280cce34b061660fe9aced64b2601cb57111cb917de181052190e4cfb4f5ba2ae24e89268a89ec23518e797035703f7bc4c2f904134235e96b
+MISC metadata.xml 430 SHA256 f428ad7aca2039cc26eaac15ebdd96e8942acd6f00a5edcfdebad255799bcf57 SHA512 38f77ee2fca730716f189a4180f92b66d3d40ca2438f26f631df28fdffe30cbec549b1066b89b06d9a02ba1e18f093954e6e211ff86694fd099e3f17503627cb WHIRLPOOL f767b25c8c978ea2f150d0d99828f545379f52ef11d8119950778859244357ad423f4b37ef37d48b649a32005f34b04df8c70cd139c576014885bcc2435de9f3
diff --git a/dev-python/rootpy/metadata.xml b/dev-python/rootpy/metadata.xml
new file mode 100644
index 000000000000..e00be2ed2d95
--- /dev/null
+++ b/dev-python/rootpy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ The rootpy project is a community-driven initiative aiming to provide
+ a more pythonic interface with ROOT on top of the existing PyROOT
+ bindings.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">rootpy</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/rootpy/rootpy-0.7.1.ebuild b/dev-python/rootpy/rootpy-0.7.1.ebuild
new file mode 100644
index 000000000000..f02f15a88d58
--- /dev/null
+++ b/dev-python/rootpy/rootpy-0.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rootpy/rootpy-0.7.1.ebuild,v 1.1 2013/08/12 17:32:01 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_USE_WITH="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd ${BUILD_DIR} || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}