summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:40:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:40:54 +0000
commit0dbb510606b0de21ed62ce08ef2bbcf7a83e91e7 (patch)
tree060eb5ccf4c5516134af3e8b961884ad0edd001c /dev-python/root_numpy/root_numpy-3.3.1.ebuild
parentVersion bump, added python-3 compat (diff)
downloadgentoo-2-0dbb510606b0de21ed62ce08ef2bbcf7a83e91e7.tar.gz
gentoo-2-0dbb510606b0de21ed62ce08ef2bbcf7a83e91e7.tar.bz2
gentoo-2-0dbb510606b0de21ed62ce08ef2bbcf7a83e91e7.zip
Version bump
(Portage version: 2.2.10.1-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/root_numpy/root_numpy-3.3.1.ebuild')
-rw-r--r--dev-python/root_numpy/root_numpy-3.3.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/root_numpy/root_numpy-3.3.1.ebuild b/dev-python/root_numpy/root_numpy-3.3.1.ebuild
new file mode 100644
index 000000000000..a25e261ce027
--- /dev/null
+++ b/dev-python/root_numpy/root_numpy-3.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/root_numpy/root_numpy-3.3.1.ebuild,v 1.1 2014/06/30 18:40:54 bicatali Exp $
+
+EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface between ROOT and numpy"
+HOMEPAGE="https://github.com/rootpy/root_numpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-physics/root[python,${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( tutorial/. )
+ distutils-r1_python_install_all
+}